p PatchFirst

CVE-2023-0507

CVE-2023-0507

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.

CVSS 7.3 · Alta · EPSS 15,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · applications

Productos y versiones afectados

  • grafana

    Versiones
    • ≥ 8.1.0, < 8.5.21: Afectada (semver)
    • ≥ 9.0.0, < 9.2.13: Afectada (semver)
    • ≥ 9.3.0, < 9.3.8: Afectada (semver)

    Actualiza a 8.5.21; Actualiza a 9.2.13; Actualiza a 9.3.8

  • grafana Ubuntu:16.04:LTS

    Versiones
    • 2.6.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →