p PatchFirst

CVE-2023-24807

CVE-2023-24807 · Undici vulnerable to Regular Expression Denial of Service in Headers

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.

CVSS 7.5 · Alta · EPSS 1,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • undici

    Versiones
    • < 5.19.1: Afectada

    Sin corrección publicada

  • node-undici Debian:12

    Versiones
    • 5.15.0+dfsg1+~cs20.10.9.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1

    Actualiza a 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1

  • node-undici Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.19.1+dfsg1+~cs20.10.9.5-1

    Actualiza a 5.19.1+dfsg1+~cs20.10.9.5-1

  • node-undici Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.19.1+dfsg1+~cs20.10.9.5-1

    Actualiza a 5.19.1+dfsg1+~cs20.10.9.5-1

  • undici npm

    Intervalos de versiones afectados
    • SEMVER: < 5.19.1

    Actualiza a 5.19.1

Fuentes originales

Comprueba tu servidor →