p PatchFirst

CVE-2023-24807

CVE-2023-24807 · Undici vulnerable to Regular Expression Denial of Service in Headers

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Undici is an HTTP/1.1 client for Node.js. Prior to version 5.19.1, the `Headers.set()` and `Headers.append()` methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the `headerValueNormalize()` utility function. This vulnerability was patched in v5.19.1. No known workarounds are available.

CVSS 7.5 · Hoch · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • undici

    Softwareversionen
    • < 5.19.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-undici Debian:12

    Softwareversionen
    • 5.15.0+dfsg1+~cs20.10.9.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1

    Auf 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1 aktualisieren

  • node-undici Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.19.1+dfsg1+~cs20.10.9.5-1

    Auf 5.19.1+dfsg1+~cs20.10.9.5-1 aktualisieren

  • node-undici Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.19.1+dfsg1+~cs20.10.9.5-1

    Auf 5.19.1+dfsg1+~cs20.10.9.5-1 aktualisieren

  • undici npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.19.1

    Auf 5.19.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →