CVE-2023-26048
CVE-2023-26048 · OutOfMemoryError for large multipart without filename in Eclipse Jetty
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Jetty is a java based web server and servlet engine. In affected versions servlets with multipart support (e.g. annotated with `@MultipartConfig`) that call `HttpServletRequest.getParameter()` or `HttpServletRequest.getParts()` may cause `OutOfMemoryError` when the client sends a multipart request with a part that has a name but no filename and very large content. This happens even with the default settings of `fileSizeThreshold=0` which should stream the whole part content to disk. An attacker client may send a large multipart request and cause the server to throw `OutOfMemoryError`. However, the server may be able to recover after the `OutOfMemoryError` and continue its service -- although it may take some time. This issue has been patched in versions 9.4.51, 10.0.14, and 11.0.14. Users are advised to upgrade. Users unable to upgrade may set the multipart parameter `maxRequestSize` which must be set to a non-negative value, so the whole multipart content is limited (although still read into memory).
CVSS 5.3 · Media · EPSS 3,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
jetty.project
- Versiones
- < 9.4.51: Afectada
- >= 10.0.0, < 10.0.14: Afectada
- >= 11.0.0, < 11.0.14: Afectada
Sin corrección publicada
jetty9 Debian:12
- Versiones
- 9.4.50-4
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.4.50-4+deb12u1
Actualiza a 9.4.50-4+deb12u1
jetty9 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.4.52-1
Actualiza a 9.4.52-1
jetty9 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.4.52-1
Actualiza a 9.4.52-1
jetty Ubuntu:14.04:LTS
- Versiones
- 6.1.26-1ubuntu1
- 6.1.26-1ubuntu1.1
- 6.1.26-1ubuntu1.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jetty Ubuntu:16.04:LTS
- Versiones
- 6.1.26-5
- 6.1.26-5ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/eclipse/jetty.project/security/advisories/GHSA-qw69-rqj8-6qw8
- https://github.com/eclipse/jetty.project/issues/9076
- https://github.com/eclipse/jetty.project/pull/9344
- https://github.com/eclipse/jetty.project/pull/9345
- https://github.com/jakartaee/servlet/blob/6.0.0/spec/src/main/asciidoc/servlet-spec-body.adoc#32-file-upload
- https://security.netapp.com/advisory/ntap-20230526-0001/
- https://www.debian.org/security/2023/dsa-5507
- https://lists.debian.org/debian-lts-announce/2023/09/msg00039.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-26048