p PatchFirst

CVE-2023-27596

CVE-2023-27596 · OpenSIPS has vulnerability in the codec_delete_XX() functions

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

CVSS 7.5 · Alta · EPSS 0,7%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • opensips

    Versiones
    • < 3.1.8: Afectada
    • >= 3.2.0, < 3.2.5: Afectada

    Sin corrección publicada

  • opensips Ubuntu:18.04:LTS

    Versiones
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →