p PatchFirst

CVE-2023-27596

CVE-2023-27596 · OpenSIPS has vulnerability in the codec_delete_XX() functions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

CVSS 7.5 · Hoch · EPSS 0,7%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • opensips

    Softwareversionen
    • < 3.1.8: Betroffen
    • >= 3.2.0, < 3.2.5: Betroffen

    Keine Korrektur veröffentlicht

  • opensips Ubuntu:18.04:LTS

    Softwareversionen
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →