CVE-2023-29197
CVE-2023-29197 · Improper header name validation in guzzlehttp/psr7
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.
CVSS 5.3 · Media · EPSS 1,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
psr7
- Versiones
- < 1.9.1: Afectada
- >= 2.0.0, < 2.4.5: Afectada
Sin corrección publicada
php-guzzlehttp-psr7 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.5-1
Actualiza a 2.4.5-1
php-guzzlehttp-psr7 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.5-1
Actualiza a 2.4.5-1
php-guzzlehttp-psr7 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.5-1
Actualiza a 2.4.5-1
php-nyholm-psr7 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.1-2
Actualiza a 1.5.1-2
php-nyholm-psr7 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.1-2
Actualiza a 1.5.1-2
php-nyholm-psr7 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.1-2
Actualiza a 1.5.1-2
guzzlehttp/psr7 Packagist
- Versiones
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.7.0
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.9.1
Actualiza a 1.9.1
guzzlehttp/psr7 Packagist
- Versiones
- 2.0.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.4.5
Actualiza a 2.4.5
php-guzzlehttp-psr7 Ubuntu:16.04:LTS
- Versiones
- 1.1.0-1
- 1.2.0-1
- 1.2.1-1
- 1.2.2-1
- 1.2.2-1build1
- 1.2.2-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-guzzlehttp-psr7 Ubuntu:20.04:LTS
- Versiones
- 1.4.2-0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.4.2-0.1+deb10u2build0.20.04.1
Actualiza a 1.4.2-0.1+deb10u2build0.20.04.1
php-nyholm-psr7 Ubuntu:20.04:LTS
- Versiones
- 1.1.0-2
- 1.2.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-guzzlehttp-psr7 Ubuntu:Pro:22.04:LTS
- Versiones
- 1.7.0-1
- 1.8.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.8.3-1ubuntu0.1~esm1
Actualiza a 1.8.3-1ubuntu0.1~esm1
php-nyholm-psr7 Ubuntu:Pro:22.04:LTS
- Versiones
- 1.3.2-2
- 1.5.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1
Actualiza a 1.5.0-1ubuntu0.1~esm1
Fuentes originales
- https://github.com/guzzle/psr7/security/advisories/GHSA-wxmh-65f7-jcvw
- https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=2022-24775
- https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/O35UN4IK6VS2LXSRWUDFWY7NI73RKY2U/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FJANWDXJZE5BGLN4MQ4FEHV5LJ6CMKQF/
- https://lists.debian.org/debian-lts-announce/2023/12/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-29197