CVE-2023-29197
CVE-2023-29197 · Improper header name validation in guzzlehttp/psr7
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Affected versions are subject to improper header parsing. An attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. This is a follow-up to CVE-2022-24775 where the fix was incomplete. The issue has been patched in versions 1.9.1 and 2.4.5. There are no known workarounds for this vulnerability. Users are advised to upgrade.
CVSS 5.3 · Mittel · EPSS 1,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
psr7
- Softwareversionen
- < 1.9.1: Betroffen
- >= 2.0.0, < 2.4.5: Betroffen
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.5-1
Auf 2.4.5-1 aktualisieren
php-guzzlehttp-psr7 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.5-1
Auf 2.4.5-1 aktualisieren
php-guzzlehttp-psr7 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.5-1
Auf 2.4.5-1 aktualisieren
php-nyholm-psr7 Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.1-2
Auf 1.5.1-2 aktualisieren
php-nyholm-psr7 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.1-2
Auf 1.5.1-2 aktualisieren
php-nyholm-psr7 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.1-2
Auf 1.5.1-2 aktualisieren
guzzlehttp/psr7 Packagist
- Softwareversionen
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.6.1
- 1.7.0
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.9.1
Auf 1.9.1 aktualisieren
guzzlehttp/psr7 Packagist
- Softwareversionen
- 2.0.0
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.4.5
Auf 2.4.5 aktualisieren
php-guzzlehttp-psr7 Ubuntu:16.04:LTS
- Softwareversionen
- 1.1.0-1
- 1.2.0-1
- 1.2.1-1
- 1.2.2-1
- 1.2.2-1build1
- 1.2.2-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:20.04:LTS
- Softwareversionen
- 1.4.2-0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.2-0.1+deb10u2build0.20.04.1
Auf 1.4.2-0.1+deb10u2build0.20.04.1 aktualisieren
php-nyholm-psr7 Ubuntu:20.04:LTS
- Softwareversionen
- 1.1.0-2
- 1.2.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
php-guzzlehttp-psr7 Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.7.0-1
- 1.8.3-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.8.3-1ubuntu0.1~esm1
Auf 1.8.3-1ubuntu0.1~esm1 aktualisieren
php-nyholm-psr7 Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.3.2-2
- 1.5.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1
Auf 1.5.0-1ubuntu0.1~esm1 aktualisieren
Originalquellen
- https://github.com/guzzle/psr7/security/advisories/GHSA-wxmh-65f7-jcvw
- https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=2022-24775
- https://www.rfc-editor.org/rfc/rfc7230#section-3.2.4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/O35UN4IK6VS2LXSRWUDFWY7NI73RKY2U/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/FJANWDXJZE5BGLN4MQ4FEHV5LJ6CMKQF/
- https://lists.debian.org/debian-lts-announce/2023/12/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-29197