CVE-2023-30541
CVE-2023-30541 · TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.
CVSS 5.3 · Media · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
openzeppelin-contracts
- Versiones
- @openzeppelin/contracts: >= 3.2.0, < 4.8.3: Afectada
- @openzeppelin/contracts-upgradeable: >=3.2.0, <4.8.3: Afectada
Sin corrección publicada
@openzeppelin/contracts npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.2.0, < 4.8.3
Actualiza a 4.8.3
@openzeppelin/contracts-upgradeable npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.2.0, < 4.8.3
Actualiza a 4.8.3