CVE-2023-30541
CVE-2023-30541 · TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.
CVSS 5.3 · Mittel · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: node
Betroffene Produkte und Versionen
openzeppelin-contracts
- Softwareversionen
- @openzeppelin/contracts: >= 3.2.0, < 4.8.3: Betroffen
- @openzeppelin/contracts-upgradeable: >=3.2.0, <4.8.3: Betroffen
Keine Korrektur veröffentlicht
@openzeppelin/contracts npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.2.0, < 4.8.3
Auf 4.8.3 aktualisieren
@openzeppelin/contracts-upgradeable npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.2.0, < 4.8.3
Auf 4.8.3 aktualisieren