p PatchFirst

CVE-2023-31130

CVE-2023-31130 · Buffer Underwrite in ares_inet_net_pton()

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

c-ares is an asynchronous resolver library. ares_inet_net_pton() is vulnerable to a buffer underflow for certain ipv6 addresses, in particular "0::00:00:00/2" was found to cause an issue. C-ares only uses this function internally for configuration purposes which would require an administrator to configure such an address via ares_set_sortlist(). However, users may externally use ares_inet_net_pton() for other purposes and thus be vulnerable to more severe issues. This issue has been fixed in 1.19.1.

CVSS 4.1 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • c-ares

    Versiones
    • < 1.19.1: Afectada

    Sin corrección publicada

  • c-ares Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.1-3

    Actualiza a 1.18.1-3

  • c-ares Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.1-3

    Actualiza a 1.18.1-3

  • c-ares Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.1-3

    Actualiza a 1.18.1-3

  • c-ares Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.10.0-2
    • 1.10.0-3
    • 1.10.0-3ubuntu0.1
    • 1.10.0-3ubuntu0.2
    • 1.10.0-3ubuntu0.2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.10.0-3ubuntu0.2+esm2

    Actualiza a 1.10.0-3ubuntu0.2+esm2

  • c-ares Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.13.0-2
    • 1.13.0-3
    • 1.14.0-1
    • 1.14.0-1ubuntu0.1
    • 1.14.0-1ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.14.0-1ubuntu0.2+esm1

    Actualiza a 1.14.0-1ubuntu0.2+esm1

  • c-ares Ubuntu:20.04:LTS

    Versiones
    • 1.15.0-1build1
    • 1.15.0-1ubuntu0.1
    • 1.15.0-1ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.15.0-1ubuntu0.3

    Actualiza a 1.15.0-1ubuntu0.3

  • c-ares Ubuntu:22.04:LTS

    Versiones
    • 1.17.1-1ubuntu1
    • 1.18.1-1
    • 1.18.1-1build1
    • 1.18.1-1ubuntu0.22.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.1-1ubuntu0.22.04.2

    Actualiza a 1.18.1-1ubuntu0.22.04.2

Fuentes originales

Comprueba tu servidor →