CVE-2023-31130
CVE-2023-31130 · Buffer Underwrite in ares_inet_net_pton()
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
c-ares is an asynchronous resolver library. ares_inet_net_pton() is vulnerable to a buffer underflow for certain ipv6 addresses, in particular "0::00:00:00/2" was found to cause an issue. C-ares only uses this function internally for configuration purposes which would require an administrator to configure such an address via ares_set_sortlist(). However, users may externally use ares_inet_net_pton() for other purposes and thus be vulnerable to more severe issues. This issue has been fixed in 1.19.1.
CVSS 4.1 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
c-ares
- Softwareversionen
- < 1.19.1: Betroffen
Keine Korrektur veröffentlicht
c-ares Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.1-3
Auf 1.18.1-3 aktualisieren
c-ares Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.1-3
Auf 1.18.1-3 aktualisieren
c-ares Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.1-3
Auf 1.18.1-3 aktualisieren
c-ares Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.10.0-2
- 1.10.0-3
- 1.10.0-3ubuntu0.1
- 1.10.0-3ubuntu0.2
- 1.10.0-3ubuntu0.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.10.0-3ubuntu0.2+esm2
Auf 1.10.0-3ubuntu0.2+esm2 aktualisieren
c-ares Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.13.0-2
- 1.13.0-3
- 1.14.0-1
- 1.14.0-1ubuntu0.1
- 1.14.0-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.14.0-1ubuntu0.2+esm1
Auf 1.14.0-1ubuntu0.2+esm1 aktualisieren
c-ares Ubuntu:20.04:LTS
- Softwareversionen
- 1.15.0-1build1
- 1.15.0-1ubuntu0.1
- 1.15.0-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.0-1ubuntu0.3
Auf 1.15.0-1ubuntu0.3 aktualisieren
c-ares Ubuntu:22.04:LTS
- Softwareversionen
- 1.17.1-1ubuntu1
- 1.18.1-1
- 1.18.1-1build1
- 1.18.1-1ubuntu0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.18.1-1ubuntu0.22.04.2
Auf 1.18.1-1ubuntu0.22.04.2 aktualisieren
Originalquellen
- https://github.com/c-ares/c-ares/security/advisories/GHSA-x6mf-cxr9-8q6v
- https://github.com/c-ares/c-ares/releases/tag/cares-1_19_1
- https://lists.fedoraproject.org/archives/list/[email protected]/message/B5Z5XFNXTNPTCBBVXFDNZQVLLIE6VRBY/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/UBFWILTA33LOSV23P44FGTQQIDRJHIY7/
- https://www.debian.org/security/2023/dsa-5419
- https://lists.debian.org/debian-lts-announce/2023/06/msg00034.html
- https://security.gentoo.org/glsa/202310-09
- https://security.netapp.com/advisory/ntap-20240605-0005/
- https://nvd.nist.gov/vuln/detail/CVE-2023-31130