CVE-2023-36814
CVE-2023-36814 · zopefoundation's Products.CMFCore vulnerable to unauthenticated denial of service and crash via unchecked use of input with Python's marshal module
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Products.CMFCore are the key framework services for the Zope Content Management Framework (CMF). The use of Python's marshal module to handle unchecked input in a public method on `PortalFolder` objects can lead to an unauthenticated denial of service and crash situation. The code in question is exposed by all portal software built on top of `Products.CMFCore`, such as Plone. All deployments are vulnerable. The code has been fixed in `Products.CMFCore` version 3.2.
CVSS 7.5 · Alta · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
products.cmfcore
- Versiones
- < 3.2: Afectada
Sin corrección publicada
products-cmfcore PyPI
- Versiones
- 3.0
- 3.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.0, < 3.2
Actualiza a 3.2
products-cmfcore PyPI
- Versiones
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.1
Actualiza a 2.7.1
products-cmfcore PyPI
- Versiones
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- 3.0
- 3.1
- 2.7.1
- Intervalos de versiones afectados
- GIT: < 40f03f43a60f28ca9485c8ef429efef729be54e5
- ECOSYSTEM: < 3.2
Actualiza a 3.2