CVE-2023-36814
CVE-2023-36814 · zopefoundation's Products.CMFCore vulnerable to unauthenticated denial of service and crash via unchecked use of input with Python's marshal module
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Products.CMFCore are the key framework services for the Zope Content Management Framework (CMF). The use of Python's marshal module to handle unchecked input in a public method on `PortalFolder` objects can lead to an unauthenticated denial of service and crash situation. The code in question is exposed by all portal software built on top of `Products.CMFCore`, such as Plone. All deployments are vulnerable. The code has been fixed in `Products.CMFCore` version 3.2.
CVSS 7.5 · Hoch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
products.cmfcore
- Softwareversionen
- < 3.2: Betroffen
Keine Korrektur veröffentlicht
products-cmfcore PyPI
- Softwareversionen
- 3.0
- 3.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0, < 3.2
Auf 3.2 aktualisieren
products-cmfcore PyPI
- Softwareversionen
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.1
Auf 2.7.1 aktualisieren
products-cmfcore PyPI
- Softwareversionen
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- 3.0
- 3.1
- 2.7.1
- Betroffene Versionsbereiche
- GIT: < 40f03f43a60f28ca9485c8ef429efef729be54e5
- ECOSYSTEM: < 3.2
Auf 3.2 aktualisieren