CVE-2023-49736
CVE-2023-49736 · Apache Superset: SQL Injection on where_in JINJA macro
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
CVSS 6.5 · Media · EPSS 1,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
apache superset
- Versiones
- ≥ 0, < 2.1.2: Afectada (semver)
- ≥ 3.0.0, < 3.0.2: Afectada (semver)
Actualiza a 2.1.2; Actualiza a 3.0.2
apache-superset PyPI
- Versiones
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.3
Actualiza a 2.1.3
apache-superset PyPI
- Versiones
- 3.0.0
- 3.0.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.0.0, < 3.0.2
Actualiza a 3.0.2
apache-superset PyPI
- Versiones
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- 3.0.0
- 3.0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.3 ∪ ≥ 3.0.0, < 3.0.2
Actualiza a 2.1.3; Actualiza a 3.0.2