CVE-2023-49736
CVE-2023-49736 · Apache Superset: SQL Injection on where_in JINJA macro
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
CVSS 6.5 · Mittel · EPSS 1,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
apache superset
- Softwareversionen
- ≥ 0, < 2.1.2: Betroffen (semver)
- ≥ 3.0.0, < 3.0.2: Betroffen (semver)
Auf 2.1.2 aktualisieren; Auf 3.0.2 aktualisieren
apache-superset PyPI
- Softwareversionen
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.3
Auf 2.1.3 aktualisieren
apache-superset PyPI
- Softwareversionen
- 3.0.0
- 3.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.0.0, < 3.0.2
Auf 3.0.2 aktualisieren
apache-superset PyPI
- Softwareversionen
- 0.34.0
- 0.34.1
- 0.35.1
- 0.35.2
- 0.36.0
- 0.37.0
- 0.37.1
- 0.37.2
- 0.38.0
- 0.38.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.1rc1
- 2.1.1rc2
- 2.1.1rc3
- 2.1.2
- 3.0.0
- 3.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.3 ∪ ≥ 3.0.0, < 3.0.2
Auf 2.1.3 aktualisieren; Auf 3.0.2 aktualisieren