p PatchFirst

CVE-2024-2236

CVE-2024-2236 · Libgcrypt: vulnerable to marvin attack

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

A timing-based side-channel flaw was found in libgcrypt's RSA implementation. This issue may allow a remote attacker to initiate a Bleichenbacher-style attack, which can lead to the decryption of RSA ciphertexts.

CVSS 5.9 · Media · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • red hat enterprise linux 9

    Versiones
    • ≥ 0:1.10.0-11.el9: No afectada (rpm)

    Sin corrección publicada

  • red hat enterprise linux 9.2 extended update support

    Versiones
    • ≥ 0:1.10.0-10.el9_2.1: No afectada (rpm)

    Sin corrección publicada

  • red hat enterprise linux 9.4 extended update support

    Versiones
    • ≥ 0:1.10.0-10.el9_4.1: No afectada (rpm)

    Sin corrección publicada

  • red hat enterprise linux 10

    Sin corrección publicada

  • red hat enterprise linux 6

    Sin corrección publicada

  • red hat enterprise linux 7

    Sin corrección publicada

  • red hat enterprise linux 8

    Sin corrección publicada

  • libgcrypt20 Debian:12

    Versiones
    • 1.10.1-3
    • 1.10.1-3+deb12u1
    • 1.10.2-1
    • 1.10.2-2
    • 1.10.2-2+loong64
    • 1.10.2-3
    • 1.10.3-1
    • 1.10.3-2
    • 1.10.3-3
    • 1.11.0+git20250114-1
    • 1.11.0-1
    • 1.11.0-2
    • 1.11.0-3
    • 1.11.0-4
    • 1.11.0-5
    • 1.11.0-6
    • 1.11.0-7
    • 1.11.0~beta450-1
    • 1.11.1-1
    • 1.11.2-1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-1
    • 1.12.0-2
    • 1.12.1-1
    • 1.12.1-2
    • 1.12.2-1
    • 1.12.3-1
    • 1.12.3-2
    • 1.12.4-1
    • 1.12.4-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Debian:13

    Versiones
    • 1.11.0+git20250114-1
    • 1.11.0-7
    • 1.11.0-7+deb13u1
    • 1.11.1-1
    • 1.11.2-1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-1
    • 1.12.0-2
    • 1.12.1-1
    • 1.12.1-2
    • 1.12.2-1
    • 1.12.3-1
    • 1.12.3-2
    • 1.12.4-1
    • 1.12.4-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Debian:14

    Versiones
    • 1.11.0+git20250114-1
    • 1.11.0-7
    • 1.11.1-1
    • 1.11.2-1
    • 1.11.2-2
    • 1.11.2-3
    • 1.12.0-1
    • 1.12.0-2
    • 1.12.1-1
    • 1.12.1-2
    • 1.12.2-1
    • 1.12.3-1
    • 1.12.3-2
    • 1.12.4-1
    • 1.12.4-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt11 Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.5.0-3ubuntu3
    • 1.5.3-2ubuntu1
    • 1.5.3-2ubuntu4
    • 1.5.3-2ubuntu4.1
    • 1.5.3-2ubuntu4.2
    • 1.5.3-2ubuntu4.3
    • 1.5.3-2ubuntu4.4
    • 1.5.3-2ubuntu4.5
    • 1.5.3-2ubuntu4.6
    • 1.5.3-2ubuntu4.6+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    • 1.6.5-2ubuntu0.6
    • 1.6.5-2ubuntu0.6+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:18.04:LTS

    Versiones
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    • 1.8.1-4ubuntu1.2
    • 1.8.1-4ubuntu1.3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS

    Versiones
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    • 1.8.1-4ubuntu1.fips.3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS

    Versiones
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:20.04:LTS

    Versiones
    • 1.8.4-5ubuntu2
    • 1.8.5-3ubuntu1
    • 1.8.5-5ubuntu1
    • 1.8.5-5ubuntu1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS

    Versiones
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    • 1.8.5-5ubuntu1.fips.1.5
    • 1.8.5-5ubuntu1.fips.1.7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS

    Versiones
    • 1.8.5-5ubuntu1.fips.1.1
    • 1.8.5-5ubuntu1.fips.1.4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:22.04:LTS

    Versiones
    • 1.8.7-5ubuntu2
    • 1.9.4-3ubuntu2
    • 1.9.4-3ubuntu3
    • 1.9.4-3ubuntu3.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.4-3ubuntu3.3

    Actualiza a 1.9.4-3ubuntu3.3

  • libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS

    Versiones
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS

    Versiones
    • 1.9.4-3ubuntu3+Fips1.1
    • 1.9.4-3ubuntu3+Fips1.2
    • 1.9.4-3ubuntu3+Fips1.3
    • 1.9.4-3ubuntu3+Fips1.4
    • 1.9.4-3ubuntu3.2+Fips1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.9.4-3ubuntu3.3+Fips1

    Actualiza a 1.9.4-3ubuntu3.3+Fips1

  • libgcrypt20 Ubuntu:24.04:LTS

    Versiones
    • 1.10.2-3ubuntu1
    • 1.10.3-2
    • 1.10.3-2build1
    • 1.10.3-2ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.10.3-2ubuntu0.2

    Actualiza a 1.10.3-2ubuntu0.2

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS

    Versiones
    • 1.10.3-2ubuntu0.1~Fips1~rc6
    • 1.10.3-2ubuntu0.1~Fips1~rc7
    • 1.12.0-2ubuntu0.1~Fips1~rc11
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.12.0-2ubuntu1.1+Fips2

    Actualiza a 1.12.0-2ubuntu1.1+Fips2

  • libgcrypt20 Ubuntu:25.10

    Versiones
    • 1.11.0-6ubuntu1
    • 1.11.0-7
    • 1.11.0-7build1
    • 1.11.0-7ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →