CVE-2024-2236
CVE-2024-2236 · Libgcrypt: vulnerable to marvin attack
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.
A timing-based side-channel flaw was found in libgcrypt's RSA implementation. This issue may allow a remote attacker to initiate a Bleichenbacher-style attack, which can lead to the decryption of RSA ciphertexts.
CVSS 5.9 · Moyenne · EPSS 1,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
red hat enterprise linux 9
- Versions du logiciel
- ≥ 0:1.10.0-11.el9: Non concernée (rpm)
Aucun correctif publié
red hat enterprise linux 9.2 extended update support
- Versions du logiciel
- ≥ 0:1.10.0-10.el9_2.1: Non concernée (rpm)
Aucun correctif publié
red hat enterprise linux 9.4 extended update support
- Versions du logiciel
- ≥ 0:1.10.0-10.el9_4.1: Non concernée (rpm)
Aucun correctif publié
red hat enterprise linux 10
Aucun correctif publié
red hat enterprise linux 6
Aucun correctif publié
red hat enterprise linux 7
Aucun correctif publié
red hat enterprise linux 8
Aucun correctif publié
libgcrypt20 Debian:12
- Versions du logiciel
- 1.10.1-3
- 1.10.1-3+deb12u1
- 1.10.2-1
- 1.10.2-2
- 1.10.2-2+loong64
- 1.10.2-3
- 1.10.3-1
- 1.10.3-2
- 1.10.3-3
- 1.11.0+git20250114-1
- 1.11.0-1
- 1.11.0-2
- 1.11.0-3
- 1.11.0-4
- 1.11.0-5
- 1.11.0-6
- 1.11.0-7
- 1.11.0~beta450-1
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- 1.12.2-1
- 1.12.3-1
- 1.12.3-2
- 1.12.4-1
- 1.12.4-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Debian:13
- Versions du logiciel
- 1.11.0+git20250114-1
- 1.11.0-7
- 1.11.0-7+deb13u1
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- 1.12.2-1
- 1.12.3-1
- 1.12.3-2
- 1.12.4-1
- 1.12.4-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Debian:14
- Versions du logiciel
- 1.11.0+git20250114-1
- 1.11.0-7
- 1.11.1-1
- 1.11.2-1
- 1.11.2-2
- 1.11.2-3
- 1.12.0-1
- 1.12.0-2
- 1.12.1-1
- 1.12.1-2
- 1.12.2-1
- 1.12.3-1
- 1.12.3-2
- 1.12.4-1
- 1.12.4-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt11 Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.5.0-3ubuntu3
- 1.5.3-2ubuntu1
- 1.5.3-2ubuntu4
- 1.5.3-2ubuntu4.1
- 1.5.3-2ubuntu4.2
- 1.5.3-2ubuntu4.3
- 1.5.3-2ubuntu4.4
- 1.5.3-2ubuntu4.5
- 1.5.3-2ubuntu4.6
- 1.5.3-2ubuntu4.6+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- 1.6.5-2ubuntu0.3
- 1.6.5-2ubuntu0.4
- 1.6.5-2ubuntu0.5
- 1.6.5-2ubuntu0.6
- 1.6.5-2ubuntu0.6+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:18.04:LTS
- Versions du logiciel
- 1.7.8-2ubuntu1
- 1.7.9-1
- 1.8.1-4
- 1.8.1-4ubuntu1
- 1.8.1-4ubuntu1.1
- 1.8.1-4ubuntu1.2
- 1.8.1-4ubuntu1.3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions du logiciel
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- 1.8.1-4ubuntu1.fips.3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS
- Versions du logiciel
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:20.04:LTS
- Versions du logiciel
- 1.8.4-5ubuntu2
- 1.8.5-3ubuntu1
- 1.8.5-5ubuntu1
- 1.8.5-5ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS
- Versions du logiciel
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- 1.8.5-5ubuntu1.fips.1.5
- 1.8.5-5ubuntu1.fips.1.7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS
- Versions du logiciel
- 1.8.5-5ubuntu1.fips.1.1
- 1.8.5-5ubuntu1.fips.1.4
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:22.04:LTS
- Versions du logiciel
- 1.8.7-5ubuntu2
- 1.9.4-3ubuntu2
- 1.9.4-3ubuntu3
- 1.9.4-3ubuntu3.2
- Plages de versions concernées
- ECOSYSTEM: < 1.9.4-3ubuntu3.3
Mettez à jour vers 1.9.4-3ubuntu3.3
libgcrypt20 Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versions du logiciel
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
libgcrypt20 Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versions du logiciel
- 1.9.4-3ubuntu3+Fips1.1
- 1.9.4-3ubuntu3+Fips1.2
- 1.9.4-3ubuntu3+Fips1.3
- 1.9.4-3ubuntu3+Fips1.4
- 1.9.4-3ubuntu3.2+Fips1
- Plages de versions concernées
- ECOSYSTEM: < 1.9.4-3ubuntu3.3+Fips1
Mettez à jour vers 1.9.4-3ubuntu3.3+Fips1
libgcrypt20 Ubuntu:24.04:LTS
- Versions du logiciel
- 1.10.2-3ubuntu1
- 1.10.3-2
- 1.10.3-2build1
- 1.10.3-2ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 1.10.3-2ubuntu0.2
Mettez à jour vers 1.10.3-2ubuntu0.2
libgcrypt20 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Versions du logiciel
- 1.10.3-2ubuntu0.1~Fips1~rc6
- 1.10.3-2ubuntu0.1~Fips1~rc7
- 1.12.0-2ubuntu0.1~Fips1~rc11
- Plages de versions concernées
- ECOSYSTEM: < 1.12.0-2ubuntu1.1+Fips2
Mettez à jour vers 1.12.0-2ubuntu1.1+Fips2
libgcrypt20 Ubuntu:25.10
- Versions du logiciel
- 1.11.0-6ubuntu1
- 1.11.0-7
- 1.11.0-7build1
- 1.11.0-7ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://access.redhat.com/errata/RHSA-2024:9404
- https://access.redhat.com/errata/RHSA-2025:3530
- https://access.redhat.com/errata/RHSA-2025:3534
- https://access.redhat.com/security/cve/CVE-2024-2236
- https://bugzilla.redhat.com/show_bug.cgi?id=2245218
- https://bugzilla.redhat.com/show_bug.cgi?id=2268268
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-2236