p PatchFirst

CVE-2024-24575

CVE-2024-24575 · libgit2 is vulnerable to a denial of service attack in `git_revparse_single`

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.

CVSS 7.5 · Alta · EPSS 1,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • libgit2

    Versiones
    • >= 1.4.0, < 1.6.5: Afectada
    • >= 1.7.0, < 1.7.2: Afectada

    Sin corrección publicada

  • libgit2 Debian:12

    Versiones
    • 1.5.1+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.1+ds-1+deb12u1

    Actualiza a 1.5.1+ds-1+deb12u1

  • libgit2 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.2+ds-1

    Actualiza a 1.7.2+ds-1

  • libgit2 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.2+ds-1

    Actualiza a 1.7.2+ds-1

Fuentes originales

Comprueba tu servidor →