p PatchFirst

CVE-2024-24575

CVE-2024-24575 · libgit2 is vulnerable to a denial of service attack in `git_revparse_single`

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

libgit2 is a portable C implementation of the Git core methods provided as a linkable library with a solid API, allowing to build Git functionality into your application. Using well-crafted inputs to `git_revparse_single` can cause the function to enter an infinite loop, potentially causing a Denial of Service attack in the calling application. The revparse function in `src/libgit2/revparse.c` uses a loop to parse the user-provided spec string. There is an edge-case during parsing that allows a bad actor to force the loop conditions to access arbitrary memory. Potentially, this could also leak memory if the extracted rev spec is reflected back to the attacker. As such, libgit2 versions before 1.4.0 are not affected. Users should upgrade to version 1.6.5 or 1.7.2.

CVSS 7.5 · Élevée · EPSS 1,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • libgit2

    Versions du logiciel
    • >= 1.4.0, < 1.6.5: Concernée
    • >= 1.7.0, < 1.7.2: Concernée

    Aucun correctif publié

  • libgit2 Debian:12

    Versions du logiciel
    • 1.5.1+ds-1
    Plages de versions concernées
    • ECOSYSTEM: < 1.5.1+ds-1+deb12u1

    Mettez à jour vers 1.5.1+ds-1+deb12u1

  • libgit2 Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.2+ds-1

    Mettez à jour vers 1.7.2+ds-1

  • libgit2 Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.7.2+ds-1

    Mettez à jour vers 1.7.2+ds-1

Sources originales

Vérifiez votre serveur →