p PatchFirst

CVE-2024-28103

CVE-2024-28103 · Action Pack is missing security headers on non-HTML responses

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Action Pack is a framework for handling and responding to web requests. Since 6.1.0, the application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This vulnerability is fixed in 6.1.7.8, 7.0.8.2, and 7.1.3.3.

CVSS 5.4 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • rails

    Versiones
    • >= 6.1.0.0, < 6.1.7.8: Afectada
    • >= 7.0.0.0, < 7.0.8.4: Afectada
    • >= 7.1.0.0, < 7.1.3.4: Afectada
    • >= 7.2.0.beta1, < 7.2.0.beta2: Afectada

    Sin corrección publicada

  • rails Debian:12

    Versiones
    • 2:6.1.7.3+dfsg-1
    • 2:6.1.7.3+dfsg-10
    • 2:6.1.7.3+dfsg-11
    • 2:6.1.7.3+dfsg-12
    • 2:6.1.7.3+dfsg-13
    • 2:6.1.7.3+dfsg-2
    • 2:6.1.7.3+dfsg-2~deb12u1
    • 2:6.1.7.3+dfsg-3
    • 2:6.1.7.3+dfsg-4
    • 2:6.1.7.3+dfsg-5
    • 2:6.1.7.3+dfsg-6
    • 2:6.1.7.3+dfsg-7
    • 2:6.1.7.3+dfsg-7~exp1
    • 2:6.1.7.3+dfsg-8
    • 2:6.1.7.3+dfsg-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:6.1.7.10+dfsg-1~deb12u1

    Actualiza a 2:6.1.7.10+dfsg-1~deb12u1

  • rails Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:7.2.2.1+dfsg-1

    Actualiza a 2:7.2.2.1+dfsg-1

  • rails Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:7.2.2.1+dfsg-1

    Actualiza a 2:7.2.2.1+dfsg-1

  • rails Ubuntu:Pro:16.04:LTS

    Versiones
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:18.04:LTS

    Versiones
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:20.04:LTS

    Versiones
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:22.04:LTS

    Versiones
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:24.04:LTS

    Versiones
    • 2:6.1.7.3+dfsg-2build1
    • 2:6.1.7.3+dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:25.10

    Versiones
    • 2:6.1.7.3+dfsg-7
    • 2:7.2.2.1+dfsg-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.10

    Versiones
    • 2:7.2.3+dfsg-2
    • 2:7.2.3.2+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.04:LTS

    Versiones
    • 2:7.2.2.1+dfsg-7
    • 2:7.2.2.2+dfsg-2
    • 2:7.2.3+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →