CVE-2024-28103
CVE-2024-28103 · Action Pack is missing security headers on non-HTML responses
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Action Pack is a framework for handling and responding to web requests. Since 6.1.0, the application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This vulnerability is fixed in 6.1.7.8, 7.0.8.2, and 7.1.3.3.
CVSS 5.4 · Mittel · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
rails
- Softwareversionen
- >= 6.1.0.0, < 6.1.7.8: Betroffen
- >= 7.0.0.0, < 7.0.8.4: Betroffen
- >= 7.1.0.0, < 7.1.3.4: Betroffen
- >= 7.2.0.beta1, < 7.2.0.beta2: Betroffen
Keine Korrektur veröffentlicht
rails Debian:12
- Softwareversionen
- 2:6.1.7.3+dfsg-1
- 2:6.1.7.3+dfsg-10
- 2:6.1.7.3+dfsg-11
- 2:6.1.7.3+dfsg-12
- 2:6.1.7.3+dfsg-13
- 2:6.1.7.3+dfsg-2
- 2:6.1.7.3+dfsg-2~deb12u1
- 2:6.1.7.3+dfsg-3
- 2:6.1.7.3+dfsg-4
- 2:6.1.7.3+dfsg-5
- 2:6.1.7.3+dfsg-6
- 2:6.1.7.3+dfsg-7
- 2:6.1.7.3+dfsg-7~exp1
- 2:6.1.7.3+dfsg-8
- 2:6.1.7.3+dfsg-9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:6.1.7.10+dfsg-1~deb12u1
Auf 2:6.1.7.10+dfsg-1~deb12u1 aktualisieren
rails Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Auf 2:7.2.2.1+dfsg-1 aktualisieren
rails Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Auf 2:7.2.2.1+dfsg-1 aktualisieren
rails Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:24.04:LTS
- Softwareversionen
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:25.10
- Softwareversionen
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.10
- Softwareversionen
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.04:LTS
- Softwareversionen
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht