p PatchFirst

CVE-2024-28184

CVE-2024-28184 · WeasyPrint allows the attachment of arbitrary files and URLs to a PDF

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

WeasyPrint helps web developers to create PDF documents. Since version 61.0, there's a vulnerability which allows attaching content of arbitrary files and URLs to a generated PDF document, even if `url_fetcher` is configured to prevent access to files and URLs. This vulnerability has been patched in version 61.2.

CVSS 7.4 · Alta · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • weasyprint

    Versiones
    • >= 61.0, <= 61.1: Afectada

    Sin corrección publicada

  • weasyprint Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 61.2-1

    Actualiza a 61.2-1

  • weasyprint Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 61.2-1

    Actualiza a 61.2-1

  • weasyprint PyPI

    Versiones
    • 61.0
    • 61.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 61.0, < 61.2

    Actualiza a 61.2

  • weasyprint Ubuntu:20.04:LTS

    Versiones
    • 50-2
    • 51-1
    • 51-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • weasyprint Ubuntu:22.04:LTS

    Versiones
    • 51-2
    • 51-3
    • 53.4-1
    • 54.0-1
    • 54.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • weasyprint Ubuntu:24.04:LTS

    Versiones
    • 59.0-1
    • 60.2-1
    • 61.0-1
    • 61.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • weasyprint Ubuntu:25.10

    Versiones
    • 62.3-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • weasyprint Ubuntu:26.10

    Versiones
    • 67.0-1
    • 69.0-1
    • 69.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • weasyprint Ubuntu:26.04:LTS

    Versiones
    • 62.3-1
    • 62.3-1build1
    • 67.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →