p PatchFirst

CVE-2024-28184

CVE-2024-28184 · WeasyPrint allows the attachment of arbitrary files and URLs to a PDF

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

WeasyPrint helps web developers to create PDF documents. Since version 61.0, there's a vulnerability which allows attaching content of arbitrary files and URLs to a generated PDF document, even if `url_fetcher` is configured to prevent access to files and URLs. This vulnerability has been patched in version 61.2.

CVSS 7.4 · Hoch · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • weasyprint

    Softwareversionen
    • >= 61.0, <= 61.1: Betroffen

    Keine Korrektur veröffentlicht

  • weasyprint Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 61.2-1

    Auf 61.2-1 aktualisieren

  • weasyprint Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 61.2-1

    Auf 61.2-1 aktualisieren

  • weasyprint PyPI

    Softwareversionen
    • 61.0
    • 61.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 61.0, < 61.2

    Auf 61.2 aktualisieren

  • weasyprint Ubuntu:20.04:LTS

    Softwareversionen
    • 50-2
    • 51-1
    • 51-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • weasyprint Ubuntu:22.04:LTS

    Softwareversionen
    • 51-2
    • 51-3
    • 53.4-1
    • 54.0-1
    • 54.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • weasyprint Ubuntu:24.04:LTS

    Softwareversionen
    • 59.0-1
    • 60.2-1
    • 61.0-1
    • 61.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • weasyprint Ubuntu:25.10

    Softwareversionen
    • 62.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • weasyprint Ubuntu:26.10

    Softwareversionen
    • 67.0-1
    • 69.0-1
    • 69.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • weasyprint Ubuntu:26.04:LTS

    Softwareversionen
    • 62.3-1
    • 62.3-1build1
    • 67.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →