CVE-2024-28188
CVE-2024-28188 · jupyter-scheduler's endpoint is missing authentication
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Jupyter Scheduler is collection of extensions for programming jobs to run now or run on a schedule. The list of conda environments of `jupyter-scheduler` users maybe be exposed, potentially revealing information about projects that a specific user may be working on. This vulnerability has been patched in version(s) 1.1.6, 1.2.1, 1.8.2 and 2.5.2.
CVSS 5.3 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
jupyter-scheduler
- Versiones
- >= 1.0.0, <= 1.1.5: Afectada
- = 1.2.0: Afectada
- >= 1.3.0, <= 1.8.1: Afectada
- >= 2.0.0, <= 2.5.1: Afectada
Sin corrección publicada
jupyter-scheduler PyPI
- Versiones
- 1.0.0
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.0, < 1.1.6
Actualiza a 1.1.6
jupyter-scheduler PyPI
- Versiones
- 1.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.2.0, < 1.2.1
Actualiza a 1.2.1
jupyter-scheduler PyPI
- Versiones
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.3.0, < 1.8.2
Actualiza a 1.8.2
jupyter-scheduler PyPI
- Versiones
- 2.0.0
- 2.1.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.5.2
Actualiza a 2.5.2
jupyter-scheduler PyPI
- Versiones
- 1.0.0
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4.0
- 1.5.0
- 1.6.0
- 1.7.0
- 1.8.0
- 1.8.1
- 2.0.0
- 2.1.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.5.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.0.0, < 1.1.6 ∪ ≥ 1.2.0, < 1.2.1 ∪ ≥ 1.3.0, < 1.8.2 ∪ ≥ 2.0.0, < 2.5.2
Actualiza a 1.1.6; Actualiza a 1.2.1; Actualiza a 1.8.2; Actualiza a 2.5.2
jupyter-server Ubuntu:22.04:LTS
- Versiones
- 1.2.2-1
- 1.13.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jupyter-server Ubuntu:24.04:LTS
- Versiones
- 1.23.3-1
- 1.23.3-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jupyter-server Ubuntu:25.10
- Versiones
- 2.14.2-5
- 2.15.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jupyter-server Ubuntu:26.10
- Versiones
- 2.17.0-1
- 2.20.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jupyter-server Ubuntu:26.04:LTS
- Versiones
- 2.15.0-1
- 2.17.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada