p PatchFirst

CVE-2024-28188

CVE-2024-28188 · jupyter-scheduler's endpoint is missing authentication

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Jupyter Scheduler is collection of extensions for programming jobs to run now or run on a schedule. The list of conda environments of `jupyter-scheduler` users maybe be exposed, potentially revealing information about projects that a specific user may be working on. This vulnerability has been patched in version(s) 1.1.6, 1.2.1, 1.8.2 and 2.5.2.

CVSS 5.3 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • jupyter-scheduler

    Softwareversionen
    • >= 1.0.0, <= 1.1.5: Betroffen
    • = 1.2.0: Betroffen
    • >= 1.3.0, <= 1.8.1: Betroffen
    • >= 2.0.0, <= 2.5.1: Betroffen

    Keine Korrektur veröffentlicht

  • jupyter-scheduler PyPI

    Softwareversionen
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.0, < 1.1.6

    Auf 1.1.6 aktualisieren

  • jupyter-scheduler PyPI

    Softwareversionen
    • 1.2.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.2.0, < 1.2.1

    Auf 1.2.1 aktualisieren

  • jupyter-scheduler PyPI

    Softwareversionen
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.3.0, < 1.8.2

    Auf 1.8.2 aktualisieren

  • jupyter-scheduler PyPI

    Softwareversionen
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.5.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.0.0, < 2.5.2

    Auf 2.5.2 aktualisieren

  • jupyter-scheduler PyPI

    Softwareversionen
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.8.0
    • 1.8.1
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.4.0
    • 2.5.0
    • 2.5.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 1.0.0, < 1.1.6 ∪ ≥ 1.2.0, < 1.2.1 ∪ ≥ 1.3.0, < 1.8.2 ∪ ≥ 2.0.0, < 2.5.2

    Auf 1.1.6 aktualisieren; Auf 1.2.1 aktualisieren; Auf 1.8.2 aktualisieren; Auf 2.5.2 aktualisieren

  • jupyter-server Ubuntu:22.04:LTS

    Softwareversionen
    • 1.2.2-1
    • 1.13.1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyter-server Ubuntu:24.04:LTS

    Softwareversionen
    • 1.23.3-1
    • 1.23.3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyter-server Ubuntu:25.10

    Softwareversionen
    • 2.14.2-5
    • 2.15.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyter-server Ubuntu:26.10

    Softwareversionen
    • 2.17.0-1
    • 2.20.0-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jupyter-server Ubuntu:26.04:LTS

    Softwareversionen
    • 2.15.0-1
    • 2.17.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →