p PatchFirst

CVE-2024-29733

CVE-2024-29733 · Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

CVSS 2.7 · Baja · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache airflow ftp provider

    Versiones
    • ≥ 0, < 3.7.0: Afectada (semver)

    Actualiza a 3.7.0

  • apache-airflow-providers-ftp PyPI

    Versiones
    • 1.0.0
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.0.1rc1
    • 1.1.0
    • 1.1.0rc1
    • 2.0.0
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.0.1
    • 2.0.1rc1
    • 2.1.0
    • 2.1.0rc1
    • 2.1.1
    • 2.1.1rc1
    • 2.1.2
    • 2.1.2rc1
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.1.0
    • 3.1.0rc1
    • 3.2.0
    • 3.2.0rc1
    • 3.3.0
    • 3.3.0rc1
    • 3.3.0rc2
    • 3.3.1
    • 3.3.1rc1
    • 3.4.0
    • 3.4.0rc1
    • 3.4.0rc2
    • 3.4.1
    • 3.4.1rc1
    • 3.4.2
    • 3.4.2rc1
    • 3.5.0
    • 3.5.0rc1
    • 3.5.1
    • 3.5.1rc1
    • 3.5.2
    • 3.5.2rc1
    • 3.6.0
    • 3.6.0rc1
    • 3.6.1
    • 3.6.1rc1
    • 3.7.0rc1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.7.0

    Actualiza a 3.7.0

Fuentes originales

Comprueba tu servidor →