p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de apache-airflow-providers-ftp

Vulnerabilidades publicadas para apache-airflow-providers-ftp en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 2

  1. CVE-2026-49486

    Alta · CVSS 7.5EPSS 0,44%Corrección disponible

    Apache Airflow FTP provider: FTP Provider does not protect FTPS data channel (missing PROT_P)

    The Apache Airflow FTP provider's `FTPSHook.get_conn()` created an `ftplib.FTP_TLS` connection but never called `prot_p()`, so although the control channel was TLS-protected the data channel was transmitted in cleartext. Any deployment using `FTPSHook` or `FTPSFileTransmitOperator` to move files over FTPS exposed file contents and credentials-in-transit to a network attacker able to observe the data connection. Upgrade apache-airflow-providers-ftp to `3.15.1` or later, which issues `PROT P` to encrypt the data channel.

    • Actualiza a 3.15.1
    Publicación Actualización
  2. CVE-2024-29733

    Baja · CVSS 2.7EPSS 0,63%Corrección disponible

    Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context

    Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

    • Actualiza a 3.7.0
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →