p PatchFirst

CVE-2024-32474

CVE-2024-32474 · Sentry's superuser cleartext password leaked in logs

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

CVSS 7.3 · Alta · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • sentry

    Versiones
    • >= 24.3.0, < 24.4.1: Afectada

    Sin corrección publicada

  • sentry PyPI

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 24.3.0, < 24.4.1

    Actualiza a 24.4.1

Fuentes originales

Comprueba tu servidor →