p PatchFirst

CVE-2024-32474

CVE-2024-32474 · Sentry's superuser cleartext password leaked in logs

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

CVSS 7.3 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • sentry

    Versions
    • >= 24.3.0, < 24.4.1: Affected

    No fix published

  • sentry PyPI

    Affected ranges
    • ECOSYSTEM: ≥ 24.3.0, < 24.4.1

    Update to 24.4.1

Original sources

Check your server →