p PatchFirst

CVE-2024-34341

CVE-2024-34341 · The Trix Editor Contains an Arbitrary Code Execution Vulnerability

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

CVSS 5.4 · Media · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • trix

    Versiones
    • < 2.1.1: Afectada

    Sin corrección publicada

  • trix npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.0.0, < 2.1.1

    Actualiza a 2.1.1

  • trix npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.9.0, < 1.3.2

    Actualiza a 1.3.2

  • actiontext RubyGems

    Versiones
    • 7.0.0
    • 7.0.0.alpha1
    • 7.0.0.alpha2
    • 7.0.0.rc1
    • 7.0.0.rc2
    • 7.0.0.rc3
    • 7.0.1
    • 7.0.2
    • 7.0.2.1
    • 7.0.2.2
    • 7.0.2.3
    • 7.0.2.4
    • 7.0.3
    • 7.0.3.1
    • 7.0.4
    • 7.0.4.1
    • 7.0.4.2
    • 7.0.4.3
    • 7.0.5
    • 7.0.5.1
    • 7.0.6
    • 7.0.7
    • 7.0.7.1
    • 7.0.7.2
    • 7.0.8
    • 7.0.8.1
    • 7.0.8.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 7.0.0.alpha1, < 7.0.8.3

    Actualiza a 7.0.8.3

  • actiontext RubyGems

    Versiones
    • 7.1.0
    • 7.1.0.beta1
    • 7.1.0.rc1
    • 7.1.0.rc2
    • 7.1.1
    • 7.1.2
    • 7.1.3
    • 7.1.3.1
    • 7.1.3.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 7.1.0.beta1, < 7.1.3.3

    Actualiza a 7.1.3.3

Fuentes originales

Comprueba tu servidor →