p PatchFirst

CVE-2024-34341

CVE-2024-34341 · The Trix Editor Contains an Arbitrary Code Execution Vulnerability

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Trix is a rich text editor. The Trix editor, versions prior to 2.1.1, is vulnerable to arbitrary code execution when copying and pasting content from the web or other documents with markup into the editor. The vulnerability stems from improper sanitization of pasted content, allowing an attacker to embed malicious scripts which are executed within the context of the application. Users should upgrade to Trix editor version 2.1.1 or later, which incorporates proper sanitization of input from copied content.

CVSS 5.4 · Mittel · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • trix

    Softwareversionen
    • < 2.1.1: Betroffen

    Keine Korrektur veröffentlicht

  • trix npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.1.1

    Auf 2.1.1 aktualisieren

  • trix npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 0.9.0, < 1.3.2

    Auf 1.3.2 aktualisieren

  • actiontext RubyGems

    Softwareversionen
    • 7.0.0
    • 7.0.0.alpha1
    • 7.0.0.alpha2
    • 7.0.0.rc1
    • 7.0.0.rc2
    • 7.0.0.rc3
    • 7.0.1
    • 7.0.2
    • 7.0.2.1
    • 7.0.2.2
    • 7.0.2.3
    • 7.0.2.4
    • 7.0.3
    • 7.0.3.1
    • 7.0.4
    • 7.0.4.1
    • 7.0.4.2
    • 7.0.4.3
    • 7.0.5
    • 7.0.5.1
    • 7.0.6
    • 7.0.7
    • 7.0.7.1
    • 7.0.7.2
    • 7.0.8
    • 7.0.8.1
    • 7.0.8.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 7.0.0.alpha1, < 7.0.8.3

    Auf 7.0.8.3 aktualisieren

  • actiontext RubyGems

    Softwareversionen
    • 7.1.0
    • 7.1.0.beta1
    • 7.1.0.rc1
    • 7.1.0.rc2
    • 7.1.1
    • 7.1.2
    • 7.1.3
    • 7.1.3.1
    • 7.1.3.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 7.1.0.beta1, < 7.1.3.3

    Auf 7.1.3.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →