p PatchFirst

CVE-2024-34716

CVE-2024-34716 · PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

CVSS 9.7 · Crítica · EPSS 56,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • prestashop

    Versiones
    • >= 8.1.0, < 8.1.6: Afectada

    Sin corrección publicada

  • prestashop/prestashop Packagist

    Versiones
    • 8.1.0
    • 8.1.1
    • 8.1.2
    • 8.1.3
    • 8.1.4
    • 8.1.5
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 8.1.0, < 8.1.6

    Actualiza a 8.1.6

Fuentes originales

Comprueba tu servidor →