p PatchFirst

CVE-2024-34716

CVE-2024-34716 · PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

CVSS 9.7 · Kritisch · EPSS 56,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • prestashop

    Softwareversionen
    • >= 8.1.0, < 8.1.6: Betroffen

    Keine Korrektur veröffentlicht

  • prestashop/prestashop Packagist

    Softwareversionen
    • 8.1.0
    • 8.1.1
    • 8.1.2
    • 8.1.3
    • 8.1.4
    • 8.1.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 8.1.0, < 8.1.6

    Auf 8.1.6 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →