CVE-2024-38357
CVE-2024-38357 · TinyMCE Cross-Site Scripting (XSS) vulnerability using noscript elements
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content parsing code. This allowed specially crafted noscript elements containing malicious code to be executed when that content was loaded into the editor. This vulnerability has been patched in TinyMCE 7.2.0, TinyMCE 6.8.4 and TinyMCE 5.11.0 LTS by ensuring that content within noscript elements are properly parsed. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 6.1 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php · python · node
Productos y versiones afectados
tinymce
- Versiones
- < 5.11.0: Afectada
- >= 6.0.0, <6.8.4: Afectada
- >= 7.0.0, < 7.2.0: Afectada
Sin corrección publicada
tinymce npm
- Intervalos de versiones afectados
- SEMVER: < 5.11.0
Actualiza a 5.11.0
tinymce NuGet
- Versiones
- 3.4.3.2
- 3.4.4
- 3.4.5
- 3.4.7
- 3.5.0
- 3.5.0.1
- 3.5.1
- 3.5.1.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.5.4.1
- 3.5.5
- 3.5.6
- 3.5.7
- 3.5.8
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.17
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.20
- 4.0.21
- 4.0.22
- 4.0.23
- 4.0.24
- 4.0.25
- 4.0.26
- 4.0.27
- 4.0.28
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.1
- 4.1.10
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.6.6
- 4.6.7
- 4.7.0
- 4.7.10
- 4.7.11
- 4.7.12
- 4.7.13
- 4.7.3
- 4.7.4
- 4.7.5
- 4.7.6
- 4.7.7
- 4.7.8
- 4.7.9
- 4.8.0
- 4.8.1
- 4.8.2
- 4.8.3
- 4.8.4
- 4.8.5
- 4.9.0
- 4.9.1
- 4.9.10
- 4.9.11
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- 4.9.8
- 4.9.9
- 5.0.0
- 5.0.1
- 5.0.10
- 5.0.11
- 5.0.12
- 5.0.13
- 5.0.14
- 5.0.15
- 5.0.16
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.7
- 5.0.8
- 5.0.9
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.10.0
- 5.10.1
- 5.10.2
- 5.10.3
- 5.10.4
- 5.10.5
- 5.10.6
- 5.10.7
- 5.10.8
- 5.10.9
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 5.4.1
- 5.4.2
- 5.5.0
- 5.5.1
- 5.6.0
- 5.6.1
- 5.6.2
- 5.7.0
- 5.7.1
- 5.8.0
- 5.8.1
- 5.8.2
- 5.9.0
- 5.9.1
- 5.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.11.0
Actualiza a 5.11.0
tinymce/tinymce Packagist
- Versiones
- 4.0.0
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.17
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.20
- 4.0.21
- 4.0.22
- 4.0.23
- 4.0.24
- 4.0.25
- 4.0.26
- 4.0.27
- 4.0.28
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.1
- 4.1.10
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.11
- 4.3.12
- 4.3.13
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.5.0
- 4.5.1
- 4.5.12
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- 4.6.4
- 4.6.5
- 4.6.6
- 4.6.7
- 4.7.0
- 4.7.1
- 4.7.10
- 4.7.11
- 4.7.12
- 4.7.13
- 4.7.2
- 4.7.3
- 4.7.4
- 4.7.5
- 4.7.6
- 4.7.7
- 4.7.8
- 4.7.9
- 4.8.0
- 4.8.1
- 4.8.2
- 4.8.3
- 4.8.4
- 4.8.5
- 4.9.0
- 4.9.1
- 4.9.10
- 4.9.11
- 4.9.2
- 4.9.3
- 4.9.4
- 4.9.5
- 4.9.6
- 4.9.7
- 4.9.8
- 4.9.9
- 5.0.0
- 5.0.1
- 5.0.10
- 5.0.11
- 5.0.12
- 5.0.13
- 5.0.14
- 5.0.15
- 5.0.16
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- 5.0.6
- 5.0.7
- 5.0.8
- 5.0.9
- 5.1.0
- 5.1.1
- 5.1.2
- 5.1.3
- 5.1.4
- 5.1.5
- 5.1.6
- 5.10.0
- 5.10.1
- 5.10.2
- 5.10.3
- 5.10.4
- 5.10.5
- 5.10.6
- 5.10.7
- 5.10.8
- 5.10.9
- 5.2.0
- 5.2.1
- 5.2.2
- 5.3.0
- 5.3.1
- 5.3.2
- 5.4.0
- 5.4.1
- 5.4.2
- 5.5.0
- 5.5.1
- 5.6.0
- 5.6.1
- 5.6.2
- 5.7.0
- 5.7.1
- 5.8.0
- 5.8.1
- 5.8.2
- 5.9.0
- 5.9.1
- 5.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.11.0
Actualiza a 5.11.0
tinymce npm
- Intervalos de versiones afectados
- SEMVER: ≥ 6.0.0, < 6.8.4
Actualiza a 6.8.4
tinymce npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.0.0, < 7.2.0
Actualiza a 7.2.0
tinymce NuGet
- Versiones
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.1.0
- 6.1.1
- 6.1.2
- 6.2.0
- 6.3.0
- 6.3.1
- 6.3.2
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.5.1
- 6.6.2
- 6.7.0
- 6.7.1
- 6.7.2
- 6.7.3
- 6.8.0
- 6.8.1
- 6.8.2
- 6.8.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.0.0, < 6.8.4
Actualiza a 6.8.4
tinymce NuGet
- Versiones
- 7.0.0
- 7.0.1
- 7.1.0
- 7.1.1
- 7.1.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.2.0
Actualiza a 7.2.0
tinymce/tinymce Packagist
- Versiones
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.1.0
- 6.1.1
- 6.1.2
- 6.2.0
- 6.3.0
- 6.3.1
- 6.3.2
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.5.1
- 6.6.0
- 6.6.1
- 6.6.2
- 6.7.0
- 6.7.1
- 6.7.2
- 6.7.3
- 6.8.0
- 6.8.1
- 6.8.2
- 6.8.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.0.0, < 6.8.4
Actualiza a 6.8.4
tinymce/tinymce Packagist
- Versiones
- 7.0.0
- 7.0.1
- 7.1.0
- 7.1.1
- 7.1.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.2.0
Actualiza a 7.2.0
django-tinymce PyPI
- Versiones
- 1.0
- 1.1
- 1.2
- 1.3
- 1.4
- 1.4.1
- 1.5
- 1.5.1
- 1.5.1.dev100
- 1.5.1.dev101
- 1.5.1a1
- 1.5.1a2
- 1.5.1a3
- 1.5.1b1
- 1.5.1b2
- 1.5.1b3
- 1.5.1b4
- 1.5.2
- 1.5.3
- 1.5.4
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.6.1
- 2.7.0
- 2.7.1
- 2.8.0
- 2.9.0
- 3.0.1
- 3.0.2
- 3.1.0
- 3.2.0
- 3.3.0
- 3.4.0
- 3.5.0
- 3.6.0
- 3.6.1
- 3.7.0
- 3.7.1
- 4.0.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.1.0
Actualiza a 4.1.0
roundcube Ubuntu:Pro:22.04:LTS
- Versiones
- 1.4.11+dfsg.1-4
- 1.5.0+dfsg.1-2
- 1.5.0+dfsg.1-2ubuntu0.1~esm1
- 1.5.0+dfsg.1-2ubuntu0.1~esm2
- 1.5.0+dfsg.1-2ubuntu0.1~esm3
- 1.5.0+dfsg.1-2ubuntu0.1~esm4
- 1.5.0+dfsg.1-2ubuntu0.1~esm5
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.5.0+dfsg.1-2ubuntu0.1~esm6
Actualiza a 1.5.0+dfsg.1-2ubuntu0.1~esm6
roundcube Ubuntu:Pro:24.04:LTS
- Versiones
- 1.6.2+dfsg-1
- 1.6.4+dfsg-1
- 1.6.5+dfsg-1
- 1.6.6+dfsg-1
- 1.6.6+dfsg-2
- 1.6.6+dfsg-2ubuntu0.1
- 1.6.6+dfsg-2ubuntu0.1+esm1
- 1.6.6+dfsg-2ubuntu0.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.6+dfsg-2ubuntu0.1+esm3
Actualiza a 1.6.6+dfsg-2ubuntu0.1+esm3
roundcube Ubuntu:25.10
- Versiones
- 1.6.10+dfsg-1
- 1.6.10+dfsg-2
- 1.6.11+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
roundcube Ubuntu:26.10
- Versiones
- 1.6.11+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
roundcube Ubuntu:Pro:26.04:LTS
- Versiones
- 1.6.11+dfsg-1
- 1.6.11+dfsg-1ubuntu0.26.04.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/tinymce/tinymce/security/advisories/GHSA-w9jx-4g6g-rp7x
- https://github.com/tinymce/tinymce/commit/5acb741665a98e83d62b91713c800abbff43b00d
- https://owasp.org/www-community/attacks/xss
- https://www.tiny.cloud/docs/tinymce/6/6.8.4-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/7/7.2-release-notes/#overview
- https://nvd.nist.gov/vuln/detail/CVE-2024-38357