CVE-2024-47174
CVE-2024-47174 · Credential leak when credentials are used with `<nix/fetchurl.nix>`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Nix is a package manager for Linux and other Unix systems. Starting in version 1.11 and prior to versions 2.18.8 and 2.24.8, `<nix/fetchurl.nix>` did not verify TLS certificates on HTTPS connections. This could lead to connection details such as full URLs or credentials leaking in case of a man-in-the-middle (MITM) attack. `<nix/fetchurl.nix>` is also known as the builtin derivation builder `builtin:fetchurl`. It's not to be confused with the evaluation-time function `builtins.fetchurl`, which was not affected by this issue. A user may be affected by the risk of leaking credentials if they have a `netrc` file for authentication, or rely on derivations with `impureEnvVars` set to use credentials from the environment. In addition, the commonplace trust-on-first-use (TOFU) technique of updating dependencies by specifying an invalid hash and obtaining it from a remote store was also vulnerable to a MITM injecting arbitrary store objects. This also applied to the impure derivations experimental feature. Note that this may also happen when using Nixpkgs fetchers to obtain new hashes when not using the fake hash method, although that mechanism is not implemented in Nix itself but rather in Nixpkgs using a fixed-output derivation. The behavior was introduced in version 1.11 to make it consistent with the Nixpkgs `pkgs.fetchurl` and to make `<nix/fetchurl.nix>` work in the derivation builder sandbox, which back then did not have access to the CA bundles by default. Nowadays, CA bundles are bind-mounted on Linux. This issue has been fixed in Nix 2.18.8 and 2.24.8. As a workaround, implement (authenticated) fetching with `pkgs.fetchurl` from Nixpkgs, using `impureEnvVars` and `curlOpts` as needed.
CVSS 5.9 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
nix
- Versiones
- >= 1.11, < 2.18.8: Afectada
- >= 2.24.0, < 2.24.8: Afectada
Sin corrección publicada
nix Debian:12
- Versiones
- 2.16.1+dfsg-1
- 2.16.1+dfsg-2
- 2.16.1+dfsg-3
- 2.17.1+dfsg-1
- 2.18.1+dfsg-1
- 2.22.1+dfsg-1
- 2.23.3+dfsg-1
- 2.23.3+dfsg-2
- 2.24.12+dfsg-1
- 2.24.8+dfsg-1
- 2.24.9+dfsg-1
- 2.24.9+dfsg-2
- 2.25.4+dfsg-1
- 2.26.3+dfsg-1
- 2.32.5+dfsg-1
- 2.32.5+dfsg-2
- 2.34.3+dfsg-1
- 2.34.6+dfsg-1
- 2.34.8+dfsg-1
- 2.8.0-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nix Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.24.8+dfsg-1
Actualiza a 2.24.8+dfsg-1
nix Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.24.8+dfsg-1
Actualiza a 2.24.8+dfsg-1
nix Ubuntu:Pro:22.04:LTS
- Versiones
- 2.3.10+dfsg1-1
- 2.3.10+dfsg1-1build1
- 2.6.0+dfsg-2
- 2.6.0+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.0+dfsg-3ubuntu0.1~esm1
Actualiza a 2.6.0+dfsg-3ubuntu0.1~esm1
nix Ubuntu:Pro:24.04:LTS
- Versiones
- 2.16.1+dfsg-3ubuntu1
- 2.18.1+dfsg-1ubuntu1
- 2.18.1+dfsg-1ubuntu2
- 2.18.1+dfsg-1ubuntu4
- 2.18.1+dfsg-1ubuntu5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.18.1+dfsg-1ubuntu5+esm2
Actualiza a 2.18.1+dfsg-1ubuntu5+esm2
Fuentes originales
- https://github.com/NixOS/nix/security/advisories/GHSA-6fjr-mq49-mm2c
- https://github.com/NixOS/nix/pull/11585
- https://github.com/NixOS/nix/commit/062b4a489e30da9c85fa4ff15cfdd2e51cac7b90
- https://github.com/NixOS/nix/commit/5db358d4d78aea7204a8f22c5bf2a309267ee038
- https://nvd.nist.gov/vuln/detail/CVE-2024-47174