p PatchFirst

CVE-2024-47174

CVE-2024-47174 · Credential leak when credentials are used with `<nix/fetchurl.nix>`

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Nix is a package manager for Linux and other Unix systems. Starting in version 1.11 and prior to versions 2.18.8 and 2.24.8, `<nix/fetchurl.nix>` did not verify TLS certificates on HTTPS connections. This could lead to connection details such as full URLs or credentials leaking in case of a man-in-the-middle (MITM) attack. `<nix/fetchurl.nix>` is also known as the builtin derivation builder `builtin:fetchurl`. It's not to be confused with the evaluation-time function `builtins.fetchurl`, which was not affected by this issue. A user may be affected by the risk of leaking credentials if they have a `netrc` file for authentication, or rely on derivations with `impureEnvVars` set to use credentials from the environment. In addition, the commonplace trust-on-first-use (TOFU) technique of updating dependencies by specifying an invalid hash and obtaining it from a remote store was also vulnerable to a MITM injecting arbitrary store objects. This also applied to the impure derivations experimental feature. Note that this may also happen when using Nixpkgs fetchers to obtain new hashes when not using the fake hash method, although that mechanism is not implemented in Nix itself but rather in Nixpkgs using a fixed-output derivation. The behavior was introduced in version 1.11 to make it consistent with the Nixpkgs `pkgs.fetchurl` and to make `<nix/fetchurl.nix>` work in the derivation builder sandbox, which back then did not have access to the CA bundles by default. Nowadays, CA bundles are bind-mounted on Linux. This issue has been fixed in Nix 2.18.8 and 2.24.8. As a workaround, implement (authenticated) fetching with `pkgs.fetchurl` from Nixpkgs, using `impureEnvVars` and `curlOpts` as needed.

CVSS 5.9 · Moyenne · EPSS 0,3% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • nix

    Versions du logiciel
    • >= 1.11, < 2.18.8: Concernée
    • >= 2.24.0, < 2.24.8: Concernée

    Aucun correctif publié

  • nix Debian:12

    Versions du logiciel
    • 2.16.1+dfsg-1
    • 2.16.1+dfsg-2
    • 2.16.1+dfsg-3
    • 2.17.1+dfsg-1
    • 2.18.1+dfsg-1
    • 2.22.1+dfsg-1
    • 2.23.3+dfsg-1
    • 2.23.3+dfsg-2
    • 2.24.12+dfsg-1
    • 2.24.8+dfsg-1
    • 2.24.9+dfsg-1
    • 2.24.9+dfsg-2
    • 2.25.4+dfsg-1
    • 2.26.3+dfsg-1
    • 2.32.5+dfsg-1
    • 2.32.5+dfsg-2
    • 2.34.3+dfsg-1
    • 2.34.6+dfsg-1
    • 2.34.8+dfsg-1
    • 2.8.0-1.1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • nix Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 2.24.8+dfsg-1

    Mettez à jour vers 2.24.8+dfsg-1

  • nix Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 2.24.8+dfsg-1

    Mettez à jour vers 2.24.8+dfsg-1

  • nix Ubuntu:Pro:22.04:LTS

    Versions du logiciel
    • 2.3.10+dfsg1-1
    • 2.3.10+dfsg1-1build1
    • 2.6.0+dfsg-2
    • 2.6.0+dfsg-3
    Plages de versions concernées
    • ECOSYSTEM: < 2.6.0+dfsg-3ubuntu0.1~esm1

    Mettez à jour vers 2.6.0+dfsg-3ubuntu0.1~esm1

  • nix Ubuntu:Pro:24.04:LTS

    Versions du logiciel
    • 2.16.1+dfsg-3ubuntu1
    • 2.18.1+dfsg-1ubuntu1
    • 2.18.1+dfsg-1ubuntu2
    • 2.18.1+dfsg-1ubuntu4
    • 2.18.1+dfsg-1ubuntu5
    Plages de versions concernées
    • ECOSYSTEM: < 2.18.1+dfsg-1ubuntu5+esm2

    Mettez à jour vers 2.18.1+dfsg-1ubuntu5+esm2

Sources originales

Vérifiez votre serveur →