CVE-2024-51741
CVE-2024-51741 · Redis allows denial-of-service due to malformed ACL selectors
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem is fixed in Redis 7.2.7 and 7.4.2.
CVSS 4.4 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- >= 7.0.0, < 7.2.7: Afectada
- >= 7.4.0, < 7.4.2: Afectada
Sin corrección publicada
redict Debian:14
- Versiones
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1~bpo12+1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.3.2+ds-1
Actualiza a 7.3.2+ds-1
redis Debian:12
- Versiones
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1~deb12u3
Actualiza a 5:7.0.15-1~deb12u3
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-3
Actualiza a 5:7.0.15-3
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-3
Actualiza a 5:7.0.15-3
valkey Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.2+dfsg1-1
Actualiza a 8.0.2+dfsg1-1
valkey Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.2+dfsg1-1
Actualiza a 8.0.2+dfsg1-1
redis Ubuntu:24.04:LTS
- Versiones
- 5:7.0.12-1
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1
- 5:7.0.15-1build1
- 5:7.0.15-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1ubuntu0.24.04.1
Actualiza a 5:7.0.15-1ubuntu0.24.04.1
valkey Ubuntu:24.04:LTS
- Versiones
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.2.8+dfsg1-0ubuntu0.24.04.2
Actualiza a 7.2.8+dfsg1-0ubuntu0.24.04.2
redict Ubuntu:25.10
- Versiones
- 7.3.2+ds-1
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.5+ds-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redict Ubuntu:26.10
- Versiones
- 7.3.6+ds-1
- 7.3.6+ds-2
- 7.3.6+ds-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redict Ubuntu:26.04:LTS
- Versiones
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.6+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada