p PatchFirst

CVE-2024-51741

CVE-2024-51741 · Redis allows denial-of-service due to malformed ACL selectors

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Redis is an open source, in-memory database that persists on disk. An authenticated with sufficient privileges may create a malformed ACL selector which, when accessed, triggers a server panic and subsequent denial of service. The problem is fixed in Redis 7.2.7 and 7.4.2.

CVSS 4.4 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · database

Betroffene Produkte und Versionen

  • redis

    Softwareversionen
    • >= 7.0.0, < 7.2.7: Betroffen
    • >= 7.4.0, < 7.4.2: Betroffen

    Keine Korrektur veröffentlicht

  • redict Debian:14

    Softwareversionen
    • 7.3.0+ds-1
    • 7.3.0+ds-2
    • 7.3.0+ds-3
    • 7.3.0+ds-3~bpo12+1
    • 7.3.1+ds-1
    • 7.3.2+ds-1~bpo12+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.3.2+ds-1

    Auf 7.3.2+ds-1 aktualisieren

  • redis Debian:12

    Softwareversionen
    • 5:7.0.11-1
    • 5:7.0.11-1+deb12u1
    • 5:7.0.12-1
    • 5:7.0.12-2
    • 5:7.0.13-1
    • 5:7.0.13-2
    • 5:7.0.14-1
    • 5:7.0.14-2
    • 5:7.0.15-1~deb12u1
    • 5:7.0.15-1~deb12u2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5:7.0.15-1~deb12u3

    Auf 5:7.0.15-1~deb12u3 aktualisieren

  • redis Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5:7.0.15-3

    Auf 5:7.0.15-3 aktualisieren

  • redis Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5:7.0.15-3

    Auf 5:7.0.15-3 aktualisieren

  • valkey Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.0.2+dfsg1-1

    Auf 8.0.2+dfsg1-1 aktualisieren

  • valkey Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.0.2+dfsg1-1

    Auf 8.0.2+dfsg1-1 aktualisieren

  • redis Ubuntu:24.04:LTS

    Softwareversionen
    • 5:7.0.12-1
    • 5:7.0.14-1
    • 5:7.0.14-2
    • 5:7.0.15-1
    • 5:7.0.15-1build1
    • 5:7.0.15-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5:7.0.15-1ubuntu0.24.04.1

    Auf 5:7.0.15-1ubuntu0.24.04.1 aktualisieren

  • valkey Ubuntu:24.04:LTS

    Softwareversionen
    • 7.2.5+dfsg1-2ubuntu4~24.04.1
    • 7.2.7+dfsg1-0ubuntu0.24.04.1
    • 7.2.8+dfsg1-0ubuntu0.24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.2.8+dfsg1-0ubuntu0.24.04.2

    Auf 7.2.8+dfsg1-0ubuntu0.24.04.2 aktualisieren

  • redict Ubuntu:25.10

    Softwareversionen
    • 7.3.2+ds-1
    • 7.3.5+ds-1
    • 7.3.5+ds-1ubuntu0.1
    • 7.3.5+ds-1ubuntu0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • redict Ubuntu:26.10

    Softwareversionen
    • 7.3.6+ds-1
    • 7.3.6+ds-2
    • 7.3.6+ds-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • redict Ubuntu:26.04:LTS

    Softwareversionen
    • 7.3.5+ds-1
    • 7.3.5+ds-1ubuntu0.1
    • 7.3.6+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →