p PatchFirst

CVE-2024-5197

CVE-2024-5197 · Integer overflow in libvpx

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond

CVSS 5.9 · Media · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • libvpx

    Versiones
    • ≥ 0, < 1.14.1: Afectada (semver)

    Actualiza a 1.14.1

  • libvpx Debian:12

    Versiones
    • 1.12.0-1
    • 1.12.0-1+deb12u1
    • 1.12.0-1+deb12u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.12.0-1+deb12u3

    Actualiza a 1.12.0-1+deb12u3

  • libvpx Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.14.1-1

    Actualiza a 1.14.1-1

  • libvpx Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.14.1-1

    Actualiza a 1.14.1-1

  • libvpx Ubuntu:Pro:14.04:LTS

    Versiones
    • 1.2.0-2
    • 1.3.0-1
    • 1.3.0-2
    • 1.3.0-2ubuntu0.1~esm1
    • 1.3.0-2ubuntu0.1~esm2
    • 1.3.0-2ubuntu0.1~esm3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.3.0-2ubuntu0.1+esm3

    Actualiza a 1.3.0-2ubuntu0.1+esm3

  • libvpx Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.4.0-4
    • 1.5.0-2
    • 1.5.0-2ubuntu1
    • 1.5.0-2ubuntu1.1
    • 1.5.0-2ubuntu1.1+esm1
    • 1.5.0-2ubuntu1.1+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.0-2ubuntu1.1+esm3

    Actualiza a 1.5.0-2ubuntu1.1+esm3

  • libvpx Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.6.1-3
    • 1.7.0-3
    • 1.7.0-3ubuntu0.18.04.1
    • 1.7.0-3ubuntu0.18.04.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.0-3ubuntu0.18.04.1+esm2

    Actualiza a 1.7.0-3ubuntu0.18.04.1+esm2

  • libvpx Ubuntu:20.04:LTS

    Versiones
    • 1.8.1-2
    • 1.8.2-1
    • 1.8.2-1build1
    • 1.8.2-1ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.8.2-1ubuntu0.3

    Actualiza a 1.8.2-1ubuntu0.3

  • libvpx Ubuntu:22.04:LTS

    Versiones
    • 1.9.0-1ubuntu1
    • 1.11.0-2ubuntu1
    • 1.11.0-2ubuntu2
    • 1.11.0-2ubuntu2.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.11.0-2ubuntu2.3

    Actualiza a 1.11.0-2ubuntu2.3

  • libvpx Ubuntu:24.04:LTS

    Versiones
    • 1.12.0-1ubuntu2
    • 1.13.1-2ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.0-1ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.14.0-1ubuntu2.1

    Actualiza a 1.14.0-1ubuntu2.1

Fuentes originales

Comprueba tu servidor →