CVE-2024-5197
CVE-2024-5197 · Integer overflow in libvpx
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
There exists interger overflows in libvpx in versions prior to 1.14.1. Calling vpx_img_alloc() with a large value of the d_w, d_h, or align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. Calling vpx_img_wrap() with a large value of the d_w, d_h, or stride_align parameter may result in integer overflows in the calculations of buffer sizes and offsets and some fields of the returned vpx_image_t struct may be invalid. We recommend upgrading to version 1.14.1 or beyond
CVSS 5.9 · Moyenne · EPSS 0,8% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
libvpx
- Versions du logiciel
- ≥ 0, < 1.14.1: Concernée (semver)
Mettez à jour vers 1.14.1
libvpx Debian:12
- Versions du logiciel
- 1.12.0-1
- 1.12.0-1+deb12u1
- 1.12.0-1+deb12u2
- Plages de versions concernées
- ECOSYSTEM: < 1.12.0-1+deb12u3
Mettez à jour vers 1.12.0-1+deb12u3
libvpx Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.14.1-1
Mettez à jour vers 1.14.1-1
libvpx Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.14.1-1
Mettez à jour vers 1.14.1-1
libvpx Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.2.0-2
- 1.3.0-1
- 1.3.0-2
- 1.3.0-2ubuntu0.1~esm1
- 1.3.0-2ubuntu0.1~esm2
- 1.3.0-2ubuntu0.1~esm3
- Plages de versions concernées
- ECOSYSTEM: < 1.3.0-2ubuntu0.1+esm3
Mettez à jour vers 1.3.0-2ubuntu0.1+esm3
libvpx Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.4.0-4
- 1.5.0-2
- 1.5.0-2ubuntu1
- 1.5.0-2ubuntu1.1
- 1.5.0-2ubuntu1.1+esm1
- 1.5.0-2ubuntu1.1+esm2
- Plages de versions concernées
- ECOSYSTEM: < 1.5.0-2ubuntu1.1+esm3
Mettez à jour vers 1.5.0-2ubuntu1.1+esm3
libvpx Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 1.6.1-3
- 1.7.0-3
- 1.7.0-3ubuntu0.18.04.1
- 1.7.0-3ubuntu0.18.04.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.7.0-3ubuntu0.18.04.1+esm2
Mettez à jour vers 1.7.0-3ubuntu0.18.04.1+esm2
libvpx Ubuntu:20.04:LTS
- Versions du logiciel
- 1.8.1-2
- 1.8.2-1
- 1.8.2-1build1
- 1.8.2-1ubuntu0.2
- Plages de versions concernées
- ECOSYSTEM: < 1.8.2-1ubuntu0.3
Mettez à jour vers 1.8.2-1ubuntu0.3
libvpx Ubuntu:22.04:LTS
- Versions du logiciel
- 1.9.0-1ubuntu1
- 1.11.0-2ubuntu1
- 1.11.0-2ubuntu2
- 1.11.0-2ubuntu2.2
- Plages de versions concernées
- ECOSYSTEM: < 1.11.0-2ubuntu2.3
Mettez à jour vers 1.11.0-2ubuntu2.3
libvpx Ubuntu:24.04:LTS
- Versions du logiciel
- 1.12.0-1ubuntu2
- 1.13.1-2ubuntu1
- 1.14.0-1ubuntu1
- 1.14.0-1ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 1.14.0-1ubuntu2.1
Mettez à jour vers 1.14.0-1ubuntu2.1