CVE-2025-11375
CVE-2025-11375 · Consul's event endpoint is vulnerable to denial of service
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Consul and Consul Enterprise’s (“Consul”) event endpoint is vulnerable to denial of service (DoS) due to lack of maximum value on the Content Length header. This vulnerability, CVE-2025-11375, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.
CVSS 6.5 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
consul
- Versiones
- ≥ 0, < 1.22.0: Afectada (semver)
Actualiza a 1.22.0
consul enterprise
- Versiones
- ≥ 0, < 1.22.0: Afectada; ≥ 1.21.6: No afectada; ≥ 1.20.8: No afectada; ≥ 1.18.12: No afectada (semver)
Actualiza a 1.18.12
consul Debian:11
- Versiones
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
consul Ubuntu:18.04:LTS
- Versiones
- 0.6.4~dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
consul Ubuntu:20.04:LTS
- Versiones
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
consul Ubuntu:22.04:LTS
- Versiones
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada