CVE-2025-11375
CVE-2025-11375 · Consul's event endpoint is vulnerable to denial of service
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Consul and Consul Enterprise’s (“Consul”) event endpoint is vulnerable to denial of service (DoS) due to lack of maximum value on the Content Length header. This vulnerability, CVE-2025-11375, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.
CVSS 6.5 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
consul
- Versions
- ≥ 0, < 1.22.0: Affected (semver)
Update to 1.22.0
consul enterprise
- Versions
- ≥ 0, < 1.22.0: Affected; ≥ 1.21.6: Not affected; ≥ 1.20.8: Not affected; ≥ 1.18.12: Not affected (semver)
Update to 1.18.12
consul Debian:11
- Versions
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:18.04:LTS
- Versions
- 0.6.4~dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:20.04:LTS
- Versions
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
consul Ubuntu:22.04:LTS
- Versions
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published