p PatchFirst

CVE-2025-13465

CVE-2025-13465 · Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.

CVSS 6.9 · Media · EPSS 1,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • lodash

    Versiones
    • ≥ 4.0.0, < 4.17.23: Afectada (semver)
    • 4.17.23: No afectada (semver)

    Actualiza a 4.17.23

  • lodash-amd

    Versiones
    • ≥ 4.0.0, < 4.17.23: Afectada (semver)
    • 4.17.23: No afectada (semver)

    Actualiza a 4.17.23

  • lodash-es

    Versiones
    • ≥ 4.0.0, < 4.17.23: Afectada (semver)
    • 4.17.23: No afectada (semver)

    Actualiza a 4.17.23

  • lodash.unset

    Versiones
    • ≥ 4.0.0, < 4.18.0: Afectada (semver)
    • 4.18.0: No afectada (semver)

    Actualiza a 4.18.0

  • lodash.omit

    Versiones
    • ≥ 4.0.0, < 4.18.0: Afectada (semver)
    • 4.18.0: No afectada (semver)

    Actualiza a 4.18.0

  • node-lodash Debian:12

    Versiones
    • 4.17.21+dfsg+~cs8.31.198.20210220-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1

  • node-lodash Debian:13

    Versiones
    • 4.17.21+dfsg+~cs8.31.198.20210220-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1

  • node-lodash Debian:14

    Versiones
    • 4.17.21+dfsg+~cs8.31.198.20210220-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-10

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-10

  • lodash npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.17.23

    Actualiza a 4.17.23

  • lodash.unset npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, ≤ 4.5.2

    Sin corrección publicada

  • lodash-es npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.17.23

    Actualiza a 4.17.23

  • lodash-amd npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.17.23

    Actualiza a 4.17.23

  • node-lodash Ubuntu:Pro:16.04:LTS

    Versiones
    • 2.4.1+dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.1+dfsg-3ubuntu0.1~esm1

    Actualiza a 2.4.1+dfsg-3ubuntu0.1~esm1

  • node-lodash Ubuntu:Pro:18.04:LTS

    Versiones
    • 4.17.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.4+dfsg-1ubuntu0.1~esm1

    Actualiza a 4.17.4+dfsg-1ubuntu0.1~esm1

  • node-lodash Ubuntu:Pro:20.04:LTS

    Versiones
    • 4.17.11+dfsg-4
    • 4.17.15+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.15+dfsg-2ubuntu0.1~esm1

    Actualiza a 4.17.15+dfsg-2ubuntu0.1~esm1

  • node-lodash Ubuntu:Pro:22.04:LTS

    Versiones
    • 4.17.21+dfsg+~cs8.31.173-1
    • 4.17.21+dfsg+~cs8.31.196.20210220-2
    • 4.17.21+dfsg+~cs8.31.198.20210220-4
    • 4.17.21+dfsg+~cs8.31.198.20210220-5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1

  • node-lodash Ubuntu:Pro:24.04:LTS

    Versiones
    • 4.17.21+dfsg+~cs8.31.198.20210220-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1

  • node-lodash Ubuntu:25.10

    Versiones
    • 4.17.21+dfsg+~cs8.31.198.20210220-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1

    Actualiza a 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1

Fuentes originales

Comprueba tu servidor →