CVE-2025-13465
CVE-2025-13465 · Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
The _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes. The issue permits deletion of properties but does not allow overwriting their original behavior. The issue is patched from 4.17.23 to 4.18.0 depending on the package: lodash, lodash-es, and lodash-amd in 4.17.23, and the standalone lodash.unset and lodash.omit packages in 4.18.0.
CVSS 6.9 · Medium · EPSS 1.8% · Fix available
- Published
- Updated
Affected products and versions
lodash
- Versions
- ≥ 4.0.0, < 4.17.23: Affected (semver)
- 4.17.23: Not affected (semver)
Update to 4.17.23
lodash-amd
- Versions
- ≥ 4.0.0, < 4.17.23: Affected (semver)
- 4.17.23: Not affected (semver)
Update to 4.17.23
lodash-es
- Versions
- ≥ 4.0.0, < 4.17.23: Affected (semver)
- 4.17.23: Not affected (semver)
Update to 4.17.23
lodash.unset
- Versions
- ≥ 4.0.0, < 4.18.0: Affected (semver)
- 4.18.0: Not affected (semver)
Update to 4.18.0
lodash.omit
- Versions
- ≥ 4.0.0, < 4.18.0: Affected (semver)
- 4.18.0: Not affected (semver)
Update to 4.18.0
node-lodash Debian:12
- Versions
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1
Update to 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1
node-lodash Debian:13
- Versions
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1
Update to 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1
node-lodash Debian:14
- Versions
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-10
Update to 4.17.21+dfsg+~cs8.31.198.20210220-10
lodash npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.17.23
Update to 4.17.23
lodash.unset npm
- Affected ranges
- SEMVER: ≥ 4.0.0, ≤ 4.5.2
No fix published
lodash-es npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.17.23
Update to 4.17.23
lodash-amd npm
- Affected ranges
- SEMVER: ≥ 4.0.0, < 4.17.23
Update to 4.17.23
node-lodash Ubuntu:Pro:16.04:LTS
- Versions
- 2.4.1+dfsg-3
- Affected ranges
- ECOSYSTEM: < 2.4.1+dfsg-3ubuntu0.1~esm1
Update to 2.4.1+dfsg-3ubuntu0.1~esm1
node-lodash Ubuntu:Pro:18.04:LTS
- Versions
- 4.17.4+dfsg-1
- Affected ranges
- ECOSYSTEM: < 4.17.4+dfsg-1ubuntu0.1~esm1
Update to 4.17.4+dfsg-1ubuntu0.1~esm1
node-lodash Ubuntu:Pro:20.04:LTS
- Versions
- 4.17.11+dfsg-4
- 4.17.15+dfsg-2
- Affected ranges
- ECOSYSTEM: < 4.17.15+dfsg-2ubuntu0.1~esm1
Update to 4.17.15+dfsg-2ubuntu0.1~esm1
node-lodash Ubuntu:Pro:22.04:LTS
- Versions
- 4.17.21+dfsg+~cs8.31.173-1
- 4.17.21+dfsg+~cs8.31.196.20210220-2
- 4.17.21+dfsg+~cs8.31.198.20210220-4
- 4.17.21+dfsg+~cs8.31.198.20210220-5
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
Update to 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1
node-lodash Ubuntu:Pro:24.04:LTS
- Versions
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
Update to 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1
node-lodash Ubuntu:25.10
- Versions
- 4.17.21+dfsg+~cs8.31.198.20210220-9
- Affected ranges
- ECOSYSTEM: < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
Update to 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1
Original sources
- https://github.com/lodash/lodash/security/advisories/GHSA-xxjr-mmjv-4gpg
- https://cna.openjsf.org/security-advisories.html
- https://cert-portal.siemens.com/productcert/html/ssa-253495.html
- https://access.redhat.com/security/cve/CVE-2025-13465
- https://bugzilla.redhat.com/show_bug.cgi?id=2431740
- https://security.access.redhat.com/data/csaf/v2/vex/2025/cve-2025-13465.json
- https://access.redhat.com/errata/RHSA-2026:33371
- https://access.redhat.com/errata/RHSA-2026:3958
- https://access.redhat.com/errata/RHSA-2026:1845
- https://access.redhat.com/errata/RHSA-2026:18480
- https://access.redhat.com/errata/RHSA-2026:24331
- https://access.redhat.com/errata/RHSA-2026:18868
- https://access.redhat.com/errata/RHSA-2026:4782
- https://access.redhat.com/errata/RHSA-2026:25089
- https://access.redhat.com/errata/RHSA-2026:2818
- https://access.redhat.com/errata/RHSA-2026:2438
- https://access.redhat.com/errata/RHSA-2026:2462
- https://access.redhat.com/errata/RHSA-2026:2469
- https://access.redhat.com/errata/RHSA-2026:2465
- https://access.redhat.com/errata/RHSA-2026:2484
- https://access.redhat.com/errata/RHSA-2026:2819
- https://access.redhat.com/errata/RHSA-2026:2817
- https://access.redhat.com/errata/RHSA-2026:2816
- https://nvd.nist.gov/vuln/detail/CVE-2025-13465