p PatchFirst

CVE-2025-15599

CVE-2025-15599 · DOMPurify XSS via Textarea Rawtext Bypass in SAFE_FOR_XML

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

DOMPurify 3.1.3 through 3.2.6 and 2.5.3 through 2.5.8 contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting missing textarea rawtext element validation in the SAFE_FOR_XML regex. Attackers can include closing rawtext tags like </textarea> in attribute values to break out of rawtext contexts and execute JavaScript when sanitized output is placed inside rawtext elements. The 3.x branch was fixed in 3.2.7; the 2.x branch was never patched.

CVSS 5.1 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • dompurify

    Versiones
    • ≥ 3.1.3, ≤ 3.2.6: Afectada (semver)
    • 3.2.7: No afectada (semver)
    • ≥ 2.5.3, ≤ 2.5.8: Afectada (semver)

    Actualiza a 3.2.7

  • node-dompurify Debian:12

    Versiones
    • 2.4.1+dfsg+~2.4.0-1
    • 2.4.1+dfsg+~2.4.0-2
    • 2.4.1+dfsg+~2.4.0-2+deb12u1
    • 3.0.9+dfsg+~3.0.5-1
    • 3.1.6+dfsg+~3.0.5-1
    • 3.1.7+dfsg+~3.0.5-1
    • 3.1.7+dfsg+~3.0.5-2
    • 3.2.5+dfsg-1
    • 3.3.2+dfsg-1
    • 3.3.3+dfsg-1
    • 3.3.3+dfsg-2
    • 3.4.1+dfsg-1
    • 3.4.12+dfsg-1
    • 3.4.13+dfsg-1
    • 3.4.13+dfsg-2
    • 3.4.16+dfsg-1
    • 3.4.2+dfsg-1
    • 3.4.5+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Debian:13

    Versiones
    • 3.1.7+dfsg+~3.0.5-2
    • 3.2.5+dfsg-1
    • 3.3.2+dfsg-1
    • 3.3.3+dfsg-1
    • 3.3.3+dfsg-2
    • 3.4.1+dfsg-1
    • 3.4.12+dfsg-1
    • 3.4.13+dfsg-1
    • 3.4.13+dfsg-2
    • 3.4.16+dfsg-1
    • 3.4.2+dfsg-1
    • 3.4.5+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Debian:14

    Versiones
    • 3.1.7+dfsg+~3.0.5-2
    • 3.2.5+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.3.2+dfsg-1

    Actualiza a 3.3.2+dfsg-1

  • dompurify npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 3.1.3, < 3.2.7

    Actualiza a 3.2.7

  • dompurify npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 2.5.3, ≤ 2.5.8

    Sin corrección publicada

  • node-dompurify Ubuntu:22.04:LTS

    Versiones
    • 2.3.0+dfsg-2
    • 2.3.3+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Ubuntu:24.04:LTS

    Versiones
    • 2.4.1+dfsg+~2.4.0-1
    • 3.0.9+dfsg+~3.0.5-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Ubuntu:25.10

    Versiones
    • 3.1.7+dfsg+~3.0.5-1
    • 3.1.7+dfsg+~3.0.5-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Ubuntu:26.10

    Versiones
    • 3.3.3+dfsg-1
    • 3.4.2+dfsg-1
    • 3.4.5+dfsg-1
    • 3.4.12+dfsg-1
    • 3.4.13+dfsg-1
    • 3.4.13+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-dompurify Ubuntu:26.04:LTS

    Versiones
    • 3.1.7+dfsg+~3.0.5-2
    • 3.3.3+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →