CVE-2025-15599
CVE-2025-15599 · DOMPurify XSS via Textarea Rawtext Bypass in SAFE_FOR_XML
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
DOMPurify 3.1.3 through 3.2.6 and 2.5.3 through 2.5.8 contain a cross-site scripting vulnerability that allows attackers to bypass attribute sanitization by exploiting missing textarea rawtext element validation in the SAFE_FOR_XML regex. Attackers can include closing rawtext tags like </textarea> in attribute values to break out of rawtext contexts and execute JavaScript when sanitized output is placed inside rawtext elements. The 3.x branch was fixed in 3.2.7; the 2.x branch was never patched.
CVSS 5.1 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
dompurify
- Softwareversionen
- ≥ 3.1.3, ≤ 3.2.6: Betroffen (semver)
- 3.2.7: Nicht betroffen (semver)
- ≥ 2.5.3, ≤ 2.5.8: Betroffen (semver)
Auf 3.2.7 aktualisieren
node-dompurify Debian:12
- Softwareversionen
- 2.4.1+dfsg+~2.4.0-1
- 2.4.1+dfsg+~2.4.0-2
- 2.4.1+dfsg+~2.4.0-2+deb12u1
- 3.0.9+dfsg+~3.0.5-1
- 3.1.6+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-2
- 3.2.5+dfsg-1
- 3.3.2+dfsg-1
- 3.3.3+dfsg-1
- 3.3.3+dfsg-2
- 3.4.1+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- 3.4.16+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Debian:13
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-2
- 3.2.5+dfsg-1
- 3.3.2+dfsg-1
- 3.3.3+dfsg-1
- 3.3.3+dfsg-2
- 3.4.1+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- 3.4.16+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Debian:14
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-2
- 3.2.5+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.2+dfsg-1
Auf 3.3.2+dfsg-1 aktualisieren
dompurify npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.1.3, < 3.2.7
Auf 3.2.7 aktualisieren
dompurify npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.5.3, ≤ 2.5.8
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:22.04:LTS
- Softwareversionen
- 2.3.0+dfsg-2
- 2.3.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:24.04:LTS
- Softwareversionen
- 2.4.1+dfsg+~2.4.0-1
- 3.0.9+dfsg+~3.0.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:25.10
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-1
- 3.1.7+dfsg+~3.0.5-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:26.10
- Softwareversionen
- 3.3.3+dfsg-1
- 3.4.2+dfsg-1
- 3.4.5+dfsg-1
- 3.4.12+dfsg-1
- 3.4.13+dfsg-1
- 3.4.13+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-dompurify Ubuntu:26.04:LTS
- Softwareversionen
- 3.1.7+dfsg+~3.0.5-2
- 3.3.3+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht