CVE-2025-23207
CVE-2025-23207 · \htmlData does not validate attribute names in KaTeX
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.
CVSS 6.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
katex
- Versiones
- >= 0.12.0, < 0.16.21: Afectada
Sin corrección publicada
node-katex Debian:12
- Versiones
- 0.16.10+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- 0.16.4+~cs6.1.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-katex Debian:13
- Versiones
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-katex Debian:14
- Versiones
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-7
Actualiza a 0.16.10+~cs6.1.0-7
katex npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.12.0, < 0.16.21
Actualiza a 0.16.21
node-katex Ubuntu:Pro:22.04:LTS
- Versiones
- 0.10.2+dfsg-8
- 0.10.2+dfsg-9
- 0.10.2+dfsg-10
- 0.13.11+~cs6.0.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
Actualiza a 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
node-katex Ubuntu:Pro:24.04:LTS
- Versiones
- 0.16.4+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu0.24.04.1~esm1
Actualiza a 0.16.10+~cs6.1.0-2ubuntu0.24.04.1~esm1
node-katex Ubuntu:25.10
- Versiones
- 0.16.10+~cs6.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu1
Actualiza a 0.16.10+~cs6.1.0-2ubuntu1
node-katex Ubuntu:26.04:LTS
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu1
Actualiza a 0.16.10+~cs6.1.0-2ubuntu1