CVE-2025-23207
CVE-2025-23207 · \htmlData does not validate attribute names in KaTeX
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
KaTeX is a fast, easy-to-use JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions with `renderToString` could encounter malicious input using `\htmlData` that runs arbitrary JavaScript, or generate invalid HTML. Users are advised to upgrade to KaTeX v0.16.21 to remove this vulnerability. Users unable to upgrade should avoid use of or turn off the `trust` option, or set it to forbid `\htmlData` commands, forbid inputs containing the substring `"\\htmlData"` and sanitize HTML output from KaTeX.
CVSS 6.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
katex
- Softwareversionen
- >= 0.12.0, < 0.16.21: Betroffen
Keine Korrektur veröffentlicht
node-katex Debian:12
- Softwareversionen
- 0.16.10+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- 0.16.4+~cs6.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-katex Debian:13
- Softwareversionen
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-katex Debian:14
- Softwareversionen
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-7
Auf 0.16.10+~cs6.1.0-7 aktualisieren
katex npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.12.0, < 0.16.21
Auf 0.16.21 aktualisieren
node-katex Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.10.2+dfsg-8
- 0.10.2+dfsg-9
- 0.10.2+dfsg-10
- 0.13.11+~cs6.0.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
Auf 0.13.11+~cs6.0.0-2ubuntu0.1~esm1 aktualisieren
node-katex Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 0.16.4+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu0.24.04.1~esm1
Auf 0.16.10+~cs6.1.0-2ubuntu0.24.04.1~esm1 aktualisieren
node-katex Ubuntu:25.10
- Softwareversionen
- 0.16.10+~cs6.1.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu1
Auf 0.16.10+~cs6.1.0-2ubuntu1 aktualisieren
node-katex Ubuntu:26.04:LTS
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-2ubuntu1
Auf 0.16.10+~cs6.1.0-2ubuntu1 aktualisieren