p PatchFirst

CVE-2025-27018

CVE-2025-27018 · Apache Airflow MySQL Provider: SQL injection in MySQL provider core function

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider. When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended. It could lead to data corruption, modification and others. This issue affects Apache Airflow MySQL Provider: before 6.2.0. Users are recommended to upgrade to version 6.2.0, which fixes the issue.

CVSS 6.3 · Media · EPSS 0,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache airflow mysql provider

    Versiones
    • ≥ 0, < 6.2.0: Afectada (semver)

    Actualiza a 6.2.0

  • apache-airflow-providers-mysql PyPI

    Versiones
    • 1.0.0
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.0.1rc1
    • 1.0.2
    • 1.0.2rc1
    • 1.1.0
    • 1.1.0rc1
    • 2.0.0
    • 2.0.0rc1
    • 2.0.0rc2
    • 2.1.0
    • 2.1.0rc1
    • 2.1.0rc2
    • 2.1.1
    • 2.1.1rc1
    • 2.2.0
    • 2.2.0rc1
    • 2.2.0rc2
    • 2.2.1
    • 2.2.1rc1
    • 2.2.2
    • 2.2.2rc1
    • 2.2.3
    • 2.2.3rc1
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.1.0
    • 3.1.0rc1
    • 3.2.0
    • 3.2.0rc1
    • 3.2.0rc2
    • 3.2.0rc3
    • 3.2.1
    • 3.2.1rc1
    • 3.3.0
    • 3.3.0rc1
    • 3.4.0
    • 3.4.0rc2
    • 3.4.0rc3
    • 4.0.0
    • 4.0.0rc1
    • 4.0.1
    • 4.0.1rc1
    • 4.0.2
    • 4.0.2rc1
    • 5.0.0
    • 5.0.0rc1
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    • 5.1.1
    • 5.1.1rc1
    • 5.2.0
    • 5.2.0rc1
    • 5.2.1
    • 5.2.1rc1
    • 5.3.0
    • 5.3.0rc1
    • 5.3.1
    • 5.3.1rc1
    • 5.4.0
    • 5.4.0rc1
    • 5.5.0
    • 5.5.0rc1
    • 5.5.1
    • 5.5.1rc1
    • 5.5.2
    • 5.5.2rc1
    • 5.5.2rc2
    • 5.5.3
    • 5.5.3rc1
    • 5.5.4
    • 5.5.4rc1
    • 5.6.0
    • 5.6.0rc1
    • 5.6.1
    • 5.6.1rc1
    • 5.6.2
    • 5.6.2rc1
    • 5.6.3
    • 5.6.3rc1
    • 5.7.0
    • 5.7.0rc1
    • 5.7.1
    • 5.7.1rc1
    • 5.7.2
    • 5.7.2rc1
    • 5.7.3
    • 5.7.3rc1
    • 5.7.4
    • 5.7.4rc1
    • 6.0.0
    • 6.0.0rc1
    • 6.0.0rc2
    • 6.1.0
    • 6.1.0rc1
    • 6.2.0rc1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.2.0

    Actualiza a 6.2.0

Fuentes originales

Comprueba tu servidor →